summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornick black2021-09-01 02:42:14 -0400
committernick black2021-09-01 02:42:14 -0400
commitdf10fd8ac3a2d96e45b576a7a76bc3ccf8cae8e0 (patch)
tree35a80f87f2c8f4ba64a2b6c3dbc3597be406a416
parentbd46bf502d1e09fd8ad9e1ff7915330d821c6fd7 (diff)
downloadaur-df10fd8ac3a2d96e45b576a7a76bc3ccf8cae8e0.tar.gz
new upstream, enable libgpm
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3642591013e..8ec2163fc1c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = notcurses
pkgdesc = Blingful TUI/character graphics library
- pkgver = 2.3.17
+ pkgver = 2.3.18
pkgrel = 1
url = https://nick-black.com/dankwiki/index.php/Notcurses
arch = x86_64
@@ -16,10 +16,11 @@ pkgbase = notcurses
makedepends = readline
makedepends = ninja
makedepends = zlib
+ makedepends = gpm
depends = ncurses
depends = ffmpeg
depends = libunistring
- source = https://github.com/dankamongmen/notcurses/archive/v2.3.17.tar.gz
- sha256sums = 81db9d13b515d01b134619f3e69cc1efe9f326030c4e49128131d3288ee68e33
+ source = https://github.com/dankamongmen/notcurses/archive/v2.3.18.tar.gz
+ sha256sums = 3748e095893e6f4f9c5d84cb66a5950ac65b11236789ebe1bc21a459beab4d72
pkgname = notcurses
diff --git a/PKGBUILD b/PKGBUILD
index 7c0166558441..beb9f321f010 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nick Black <dankamongmen@gmail.com>
pkgname=notcurses
-pkgver=2.3.17
+pkgver=2.3.18
pkgrel=1
pkgdesc="Blingful TUI/character graphics library"
url="https://nick-black.com/dankwiki/index.php/Notcurses"
@@ -11,13 +11,13 @@ arch=('x86_64')
# dynamic library. Should the .so be shipped in the future, promote qrcodegen
# from a makedepends to a true depends, and use that dynamic library.
depends=('ncurses' 'ffmpeg' 'libunistring')
-makedepends=('cmake' 'pandoc' 'python-pip' 'python-pypandoc' 'python-cffi' 'python-setuptools' 'doctest' 'qrcodegen' 'readline' 'ninja' 'zlib')
+makedepends=('cmake' 'pandoc' 'python-pip' 'python-pypandoc' 'python-cffi' 'python-setuptools' 'doctest' 'qrcodegen' 'readline' 'ninja' 'zlib' 'gpm')
source=("https://github.com/dankamongmen/notcurses/archive/v${pkgver}.tar.gz")
prepare() {
mkdir -p "${pkgname}-${pkgver}/build"
cd "${pkgname}-${pkgver}/build"
- cmake .. -GNinja -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=RelWithDebInfo -DUSE_QRCODEGEN=on
+ cmake .. -GNinja -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_BUILD_TYPE=RelWithDebInfo -DUSE_QRCODEGEN=on -DUSE_GPM=on
}
build() {
@@ -37,4 +37,4 @@ package() {
env CFLAGS="-I$pkgdir/usr/include -L../build" python setup.py install --root="$pkgdir" --optimize=1
}
-sha256sums=('81db9d13b515d01b134619f3e69cc1efe9f326030c4e49128131d3288ee68e33')
+sha256sums=('3748e095893e6f4f9c5d84cb66a5950ac65b11236789ebe1bc21a459beab4d72')