summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Schoon2020-09-14 13:55:37 -0500
committerKevin Schoon2020-09-14 13:55:37 -0500
commit78dc94296fe6d07f0525ad6ae966c9b10c53e02b (patch)
tree57e23a7a4a8f6f115f4e67fa90718a294cef7642
downloadaur-78dc94296fe6d07f0525ad6ae966c9b10c53e02b.tar.gz
init
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD16
3 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8f29e548873
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = note-bin
+ pkgdesc = Simple Note Taking CLI
+ pkgver = 0.5.4
+ pkgrel = 1
+ url = https://github.com/kevinschoon/note
+ arch = x86_64
+ license = AGPL3
+ source = note-glibc-0.5.4.tar.gz::https://github.com/kevinschoon/note/releases/download/0.5.4/note-glibc-0.5.4.tar.gz
+ md5sums = e1a2b7df553ca3cf9971ce7685bef272
+
+pkgname = note-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e7659a8c1186
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+note-*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91da53ef8cc9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Kevin Schoon <kevinschoon@gmail.com>
+pkgname=note-bin
+pkgver=0.5.4
+pkgrel=1
+pkgdesc="Simple Note Taking CLI"
+url="https://github.com/kevinschoon/note"
+arch=(x86_64)
+license=('AGPL3')
+source=("note-glibc-0.5.4.tar.gz::https://github.com/kevinschoon/note/releases/download/0.5.4/note-glibc-0.5.4.tar.gz")
+md5sums=(e1a2b7df553ca3cf9971ce7685bef272)
+
+package() {
+ install -Dm755 usr/bin/note -t "${pkgdir}/usr/bin/"
+ install -Dm644 usr/share/bash-completion/completions/note -t ${pkgdir}/usr/share/bash-completion/completions/
+ install -Dm644 usr/share/man/man7/note.7.gz -t ${pkgdir}/usr/share/man/man7/
+}