summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel Palhas2020-06-26 19:12:36 +0100
committerMiguel Palhas2020-06-26 19:12:36 +0100
commitdd14d642039a6afb1d7d461187eaf407be2b01dc (patch)
treeea6cd96c2b7dd88827190a89e2bf5c39a4bee17c
downloadaur-dd14d642039a6afb1d7d461187eaf407be2b01dc.tar.gz
First version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD29
-rw-r--r--icon.pngbin0 -> 55529 bytes
-rw-r--r--notedown.desktop8
4 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7b8024e9c67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = pkgbase
+ pkgdesc = Japanese-Russian kanji and word dictionary
+ pkgver = 1.10
+ pkgrel = 1
+ url = http://www.susi.ru/yarxi/
+ arch = x86_64
+ license = custom
+ depends = ttf-sazanami
+ depends = nas
+
+pkgname = yarxi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f890a8572f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=notedown
+pkgver=1.5
+filever=1.0.0
+pkgrel=1
+pkgdesc=""
+arch=('any')
+url="https://github.com/subvisual/notedown/releases/download/v$pkgver/$pkgname-$filever.tar.gz"
+license=('MPL')
+depends=('electron')
+makedepends=('git')
+source=($url "notedown.desktop" "icon.png")
+noextract=()
+md5sums=('SKIP' '647ca7e77794a5f19c47b5c37261372e' '760e3507b86c1379f33f8d38ea894dc3')
+
+package() {
+ echo $srcdir
+ mkdir -p ${pkgdir}/opt/${pkgname}
+ mkdir -p ${pkgdir}/usr/bin/
+ mkdir -p ${pkgdir}/usr/share/icons/hicolor/256x256/apps/
+ mkdir -p ${pkgdir}/usr/share/applications/
+
+ cp -r "${srcdir}/${pkgname}-${filever}/"* "${pkgdir}/opt/${pkgname}" -R
+ cp "${srcdir}/notedown.desktop" "${pkgdir}/usr/share/applications/notedown.desktop"
+ cp "${srcdir}/icon.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/notedown.png"
+
+ # link executable to /usr/bin
+ ln -s "${pkgdir}/opt/${pkgname}/notedown" "${pkgdir}"/usr/bin/notedown
+
+}
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..97a9dec0e590
--- /dev/null
+++ b/icon.png
Binary files differ
diff --git a/notedown.desktop b/notedown.desktop
new file mode 100644
index 000000000000..9f3983c96bd3
--- /dev/null
+++ b/notedown.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=NoteDown
+Exec=/usr/bin/notedown %&
+Terminal=false
+Type=Application
+Icon=notedown
+StartupWMClass=NoteDown
+Categories=GNOME;GTK;Network;InstantMessaging;