summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2018-03-04 15:03:51 +0100
committergrufo2018-03-04 15:03:51 +0100
commit02435cc795f874345c41076165ab0f22ad89bb2c (patch)
treea0d2368224cc8a5d0d166cd9e1b0dd39591d5e47
downloadaur-02435cc795f874345c41076165ab0f22ad89bb2c.tar.gz
First release (1.3.8)
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4775b06e8ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = notejot
+ pkgdesc = A stupidly-simple sticky notes application for any type of short term notes or ideas
+ pkgver = 1.3.8
+ pkgrel = 1
+ url = https://madmurphy.github.io/libconfini/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = meson
+ depends = granite
+ depends = gtk3
+ depends = gtksourceview3
+ depends = json-glib
+ depends = libgee
+ conflicts = notejot-git
+ source = https://github.com/lainsce/notejot/archive/1.3.8.tar.gz
+ md5sums = 7608aab5ca91ce02ce9f58b4a931e832
+
+pkgname = notejot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d7c9662410e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: grufo <madmurphy333@gmail.com>
+
+pkgname='notejot'
+pkgver='1.3.8'
+pkgrel=1
+pkgdesc='A stupidly-simple sticky notes application for any type of short term notes or ideas'
+arch=('i686' 'x86_64')
+url='https://madmurphy.github.io/libconfini/'
+license=('GPL')
+depends=('granite' 'gtk3' 'gtksourceview3' 'json-glib' 'libgee')
+makedepends=('meson')
+conflicts=('notejot-git')
+source=("https://github.com/lainsce/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('7608aab5ca91ce02ce9f58b4a931e832')
+
+build() {
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ meson build
+ cd build
+ meson configure -Dprefix=/usr
+
+}
+
+package() {
+
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+ DESTDIR="${pkgdir}" ninja install
+
+}
+
+