summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-05-06 09:45:18 +0800
committerzxp198210052023-05-06 09:45:18 +0800
commit3dd534573bd34a30d1d8e4a9f9de354142ff5923 (patch)
tree2a0e6c97a1d1aad139db43be658bda3a20f413f7
downloadaur-3dd534573bd34a30d1d8e4a9f9de354142ff5923.tar.gz
first release
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4edda206545
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = notekit-appimage
+ pkgdesc = A GTK3 hierarchical markdown notetaking application with tablet support.
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/blackhole89/notekit
+ arch = x86_64
+ license = GPL3
+ depends = glibc
+ conflicts = notekit
+ options = !strip
+ source = notekit-0.2.0.AppImage::https://github.com/blackhole89/notekit/releases/download/v0.2.0/notekit-0.2.0+git1.73c1a86-Build6.1.glibc2.14-x86_64.AppImage
+ sha256sums = bf17231318c8017a90d1df84ccc9675235fddc2cc0616b4a7151766f5b0c7ae3
+
+pkgname = notekit-appimage
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6e2d6e67088
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="notekit-appimage"
+_appname="com.github.blackhole89.notekit"
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A GTK3 hierarchical markdown notetaking application with tablet support."
+arch=('x86_64')
+url="https://github.com/blackhole89/notekit"
+license=('GPL3')
+depends=('glibc')
+options=(!strip)
+conflicts=("${pkgname%-appimage}")
+_install_path="/opt/appimages"
+source=("${pkgname%-appimage}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${pkgname%-appimage}-${pkgver}+git1.73c1a86-Build6.1.glibc2.14-x86_64.AppImage")
+sha256sums=('bf17231318c8017a90d1df84ccc9675235fddc2cc0616b4a7151766f5b0c7ae3')
+
+prepare() {
+ chmod a+x "${pkgname%-appimage}-${pkgver}.AppImage"
+ "./${pkgname%-appimage}-${pkgver}.AppImage" --appimage-extract > /dev/null
+ sed 's|Exec=notekit|Exec=/opt/appimages/notekit.AppImage|g;s|com.github.blackhole89.notekit|notekit|g' -i "${srcdir}/squashfs-root/${_appname}.desktop"
+}
+
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-appimage}-${pkgver}.AppImage" "${pkgdir}/${_install_path}/${pkgname%-appimage}.AppImage"
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/128x128/apps/${_appname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-appimage}.png"
+ install -Dm644 "${srcdir}/squashfs-root/${_appname}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-appimage}.desktop"
+} \ No newline at end of file