summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorstarsareintherose2021-12-16 03:59:03 +0000
committerstarsareintherose2021-12-16 03:59:03 +0000
commit500ca6c67c9efcbf413287ad035cf42e95a902c3 (patch)
tree3a025fb9edca0fc5cf5709e91cd469b3911105ca
parentab4d90e44f67b1faf0e9d66341bf3bc4f2492f9e (diff)
downloadaur-500ca6c67c9efcbf413287ad035cf42e95a902c3.tar.gz
new build
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD62
2 files changed, 36 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbb29aeb1b97..aace8e384ff1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,27 @@
pkgbase = notekit-git
pkgdesc = A GTK3 hierarchical markdown notetaking application with tablet support.
- pkgver = r56.1581970
+ pkgver = r208.844215a
pkgrel = 1
url = https://github.com/blackhole89/notekit
arch = x86_64
- license = GPL3
- makedepends = gcc
- makedepends = make
- makedepends = cmake
- depends = gtkmm3>=3.2
+ arch = aarch64
+ arch = i686
+ arch = armv7h
+ arch = s390x
+ license = GPL-3.0
+ makedepends = git
+ makedepends = meson
+ makedepends = pkgconf
+ depends = fontconfig
+ depends = clatexmath
+ depends = gtkmm3
depends = gtksourceviewmm>=3.18
depends = jsoncpp
depends = zlib
- source = git+https://github.com/blackhole89/notekit.git
+ provides = notekit
+ conflicts = notekit
+ conflicts = notekit-git
+ source = notekit::git+https://github.com/blackhole89/notekit.git
sha256sums = SKIP
pkgname = notekit-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f6251f3c0b9e..eda9be50988f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,35 @@
-pkgname=notekit-git
-basename=${pkgname%-git}
-pkgver=r56.1581970
+# Maintainer: Guoyi Zhang
+_basename=notekit
+pkgname="${_basename}-git"
+pkgver=r208.844215a
pkgrel=1
pkgdesc="A GTK3 hierarchical markdown notetaking application with tablet support."
-arch=('x86_64')
+arch=("x86_64" "aarch64" "i686" "armv7h" "s390x")
url="https://github.com/blackhole89/notekit"
-license=('GPL3')
-depends=('gtkmm3>=3.2' 'gtksourceviewmm>=3.18' 'jsoncpp' 'zlib')
-makedepends=('gcc' 'make' 'cmake')
-source=('git+https://github.com/blackhole89/notekit.git')
-sha256sums=('SKIP')
+license=("GPL-3.0")
+depends=("fontconfig" "clatexmath" "gtkmm3" "gtksourceviewmm>=3.18" "jsoncpp" "zlib")
+makedepends=("git" "meson" "pkgconf")
+provides=("${_basename}")
+conflicts=("${_basename}" "${_basename}-git")
+source=("${_basename}::git+https://github.com/blackhole89/notekit.git")
+sha256sums=("SKIP")
pkgver() {
- cd "$srcdir/$basename"
+ cd "${srcdir}/${_basename}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare(){
- #workaround for "sub-command STRIP requires two arguments" error
- sed -i 's/${CL_TMP_VAR}/"${CL_TMP_VAR}"/g' "$srcdir"/notekit/CMakeLists.txt
+prepare() {
+ cd "${srcdir}/${_basename}"
+ arch-meson . _build
}
build() {
- cd "$srcdir/$basename"
- cmake .
- make
+ cd "${srcdir}/${_basename}"
+ ninja -C _build
}
package() {
- #install binary
- install -Dm755 "$srcdir"/notekit/cmake-build-Release/output/notekit -t "$pkgdir"/usr/bin/
-
- #install doc
- install -Dm644 "$srcdir"/notekit/README.md -t "$pkgdir"/usr/share/doc/notekit/
-
- #install license
- install -Dm644 "$srcdir"/notekit/LICENSE -t "$pkgdir"/usr/share/licenses/
-
- #install "data" and "sourceview"
- mkdir -p "$pkgdir"/usr/share/notekit/
- cp -r "$srcdir"/notekit/data "$srcdir"/notekit/sourceview "$pkgdir"/usr/share/notekit/
-
- #install desktop shortcut (taken from lyessaadi/notekit on COPR and modified to fit Arch)
- mkdir -p "$pkgdir"/usr/share/applications/
- echo "[Desktop Entry]
-Version="$pkgver"
-Name=NoteKit
-GenericName=NoteKit
-Comment=Write your notes in instantly-formatted Markdown
-Icon=accessories-text-editor
-Exec=notekit
-Terminal=false
-Type=Application
-Categories=Office;
-Keywords=note;onenote;notetaking;markdown;" > "$pkgdir"/usr/share/applications/notekit.desktop
+ cd "${srcdir}/${_basename}"
+ DESTDIR="${pkgdir}" meson install -C _build
}