summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorseal attack2021-06-13 20:41:28 +0100
committerseal attack2021-06-13 20:41:28 +0100
commit7e358be85fb8327c41f1ada0d229e0b6bfb6a52e (patch)
tree9178229fc6b0ae31c362ac5692097a5067f90399
downloadaur-7e358be85fb8327c41f1ada0d229e0b6bfb6a52e.tar.gz
add aur required files
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..628a5683bf7d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = notepac
+ pkgdesc = Make notes about your installed packages
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://gitlab.com/vaba/notepac
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cargo
+ source = git+https://gitlab.com/vaba/notepac#tag=v0.1.2
+ md5sums = SKIP
+
+pkgname = notepac
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62b07aaca9c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: vaba <aur.demifusion@8shield.net>
+pkgname=notepac
+_gitname=notepac
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="Make notes about your installed packages"
+url="https://gitlab.com/vaba/notepac"
+license=("GPL3")
+source=("git+$url#tag=v$pkgver")
+md5sums=("SKIP")
+arch=("x86_64")
+makedepends=("git" "cargo")
+
+build() {
+ cd $_gitname
+ cargo build --release
+}
+
+package() {
+ cd $_gitname
+ install -Dm755 --no-target-directory "src/args-collector.sh" "$pkgdir/usr/bin/${pkgname}"
+ install -Dm755 --target-directory="$pkgdir/usr/lib/${pkgname}" "target/release/note-manager"
+}