summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2024-03-25 18:15:21 +0100
committerbegin-theadventure2024-03-25 18:15:21 +0100
commit1d5dbc71f559534925b54e655b29024b2942c5bb (patch)
tree2672a33f02cda90d22ab21d4c3deaa47fd35f491
parent21426e778d84eceff54f02616c91d49e92dd9341 (diff)
downloadaur-1d5dbc71f559534925b54e655b29024b2942c5bb.tar.gz
1.0.10, SPDX license, check, package, & clean up
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ed4acccebc1..879e8c202ead 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = notepad
pkgdesc = A simple notepad for GNU/Linux distributions
- pkgver = 1.2.5
+ pkgver = 1.2.6
pkgrel = 1
url = https://github.com/alexkdeveloper/notepad
- arch = aarch64
arch = x86_64
- license = GPL3
+ arch = aarch64
+ license = GPL-3.0-or-later
checkdepends = appstream-glib
makedepends = git
makedepends = meson
makedepends = vala
depends = libadwaita
- source = git+https://github.com/alexkdeveloper/notepad.git#tag=1.2.5
+ source = git+https://github.com/alexkdeveloper/notepad.git#tag=1.2.6
sha256sums = SKIP
pkgname = notepad
diff --git a/PKGBUILD b/PKGBUILD
index 3f4108b1f614..78bd750aad1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
pkgname=notepad
-pkgdesc='A simple notepad for GNU/Linux distributions'
-pkgver=1.2.5
+pkgver=1.2.6
pkgrel=1
-arch=('aarch64' 'x86_64')
+pkgdesc='A simple notepad for GNU/Linux distributions'
url="https://github.com/alexkdeveloper/notepad"
-license=('GPL3')
+license=('GPL-3.0-or-later')
+arch=('x86_64' 'aarch64')
depends=('libadwaita')
makedepends=('git' 'meson' 'vala')
checkdepends=('appstream-glib')
@@ -14,7 +14,7 @@ source=("git+$url.git#tag=$pkgver")
sha256sums=('SKIP')
build() {
- arch-meson $pkgname build
+ arch-meson notepad build
meson compile -C build
}
@@ -23,6 +23,6 @@ check() {
}
package() {
- DESTDIR="$pkgdir" meson install -C build
- ln -s com.github.alexkdeveloper.$pkgname "$pkgdir/usr/bin/$pkgname.alexkdeveloper"
+ meson install -C build --destdir "$pkgdir"
+ ln -s com.github.alexkdeveloper.notepad "$pkgdir/usr/bin/notepad.alexkdeveloper"
}