summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2024-03-11 16:04:17 +0800
committertaotieren2024-03-11 16:04:17 +0800
commit134fb33a6b463fd51927370a8e9d5864ca746cb3 (patch)
tree52c5315079fb07a1f358e5d224cab905e512eb43
parente11cdf427d330255354192ee80a3d591198be53b (diff)
downloadaur-134fb33a6b463fd51927370a8e9d5864ca746cb3.tar.gz
[lilac] updated to 2.14.r1.g335b72c-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e37d2a0f5fe5..e3c7283f66a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = notepad---git
pkgdesc = Notepad-- 是使用C++编写的轻量级文本编辑器, 简称ndd, 可以支持Window/Mac/Linux操作系统平台。
- pkgver = 2.12.r5.ga89e9c6
- pkgrel = 3
+ pkgver = 2.14.r1.g335b72c
+ pkgrel = 1
url = https://gitee.com/cxasm/notepad--
arch = x86_64
license = GPL-3.0-or-later
@@ -9,9 +9,12 @@ pkgbase = notepad---git
makedepends = ninja
makedepends = git
makedepends = qt5-tools
+ makedepends = qt5-xmlpatterns
+ makedepends = qscintilla-qt5
+ depends = glibc
+ depends = gcc-libs
+ depends = hicolor-icon-theme
depends = qt5-base
- depends = qt5-xmlpatterns
- depends = qscintilla-qt5
provides = notepad--
provides = notepadplugin
conflicts = notepad--
diff --git a/PKGBUILD b/PKGBUILD
index d5056be1e99f..9228d381f296 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: taotieren <admin@taotieren.com>
pkgname=notepad---git
-pkgver=2.12.r5.ga89e9c6
-pkgrel=3
+pkgver=2.14.r1.g335b72c
+pkgrel=1
pkgdesc="Notepad-- 是使用C++编写的轻量级文本编辑器, 简称ndd, 可以支持Window/Mac/Linux操作系统平台。"
arch=('x86_64')
url="https://gitee.com/cxasm/notepad--"
@@ -10,13 +10,17 @@ license=('GPL-3.0-or-later')
provides=(${pkgname%-git} notepadplugin)
conflicts=(${pkgname%-git})
_qt=qt5
-depends=($_qt-base
- $_qt-xmlpatterns
- qscintilla-$_qt)
+depends=(
+ glibc
+ gcc-libs
+ hicolor-icon-theme
+ $_qt-base)
makedepends=(cmake
ninja
git
- $_qt-tools)
+ $_qt-tools
+ $_qt-xmlpatterns
+ qscintilla-$_qt)
source=("${pkgname}::git+${url}.git")
sha256sums=('SKIP')
@@ -40,7 +44,7 @@ build() {
sed -i '7s/NotePad--/notepad--/' src/linux/usr/share/applications/NotePad--.desktop
- cmake -D CMAKE_BUILD_TYPE=None \
+ cmake -D CMAKE_BUILD_TYPE=Release \
-D CMAKE_INSTALL_PREFIX=/usr \
-B build \
-G Ninja \