summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2024-02-23 21:47:54 +0100
committerbegin-theadventure2024-02-23 21:47:54 +0100
commitc3bd31cc13951cea367cb6272ff16f0121d4e6d3 (patch)
tree22aba570c42cd5a9d80bf4641219a14368c5c42b
parenteb772e10b4200ef0ebec3b05bab4c214bb7f071f (diff)
downloadaur-c3bd31cc13951cea367cb6272ff16f0121d4e6d3.tar.gz
0.7, clean up
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD33
2 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbd0fd521db1..9b085d901507 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = notepadnext-bin
pkgdesc = A cross-platform, reimplementation of Notepad++ (binary release)
- pkgver = 0.6.4
+ pkgver = 0.7
pkgrel = 1
url = https://github.com/dail8859/NotepadNext
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = notepadnext-bin
provides = notepadnext
conflicts = notepadnext
options = !strip
- source = https://github.com/dail8859/NotepadNext/releases/download/v0.6.4/NotepadNext-v0.6.4-x86_64.AppImage
- sha256sums = b26e2d5208bce3b70847f1b7c5f863cd7567bd476dd3df68ad433c700564a089
+ source = https://nightly.link/dail8859/NotepadNext/actions/runs/8009956505/NotepadNext-Linux-Qt6.6-AppImage.zip
+ sha256sums = 7b3f0802f4a3dd16afcb66cbd71f1a1f62458003fae324ddc93c2e116d7ce652
pkgname = notepadnext-bin
diff --git a/PKGBUILD b/PKGBUILD
index b4d45fd56b16..2f35fc2e1ec2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,37 @@
# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
-_pkgname=notepadnext
-pkgname=$_pkgname-bin
-pkgver=0.6.4
+pkgname=notepadnext-bin
+pkgver=0.7
pkgrel=1
pkgdesc="A cross-platform, reimplementation of Notepad++ (binary release)"
-arch=('x86_64')
url="https://github.com/dail8859/NotepadNext"
license=('GPL3')
+arch=('x86_64')
makedepends=('fuse2')
-conflicts=($_pkgname)
-provides=($_pkgname)
+conflicts=("notepadnext")
+provides=("notepadnext")
options=(!strip)
-source=("$url/releases/download/v$pkgver/NotepadNext-v$pkgver-x86_64.AppImage")
-sha256sums=('b26e2d5208bce3b70847f1b7c5f863cd7567bd476dd3df68ad433c700564a089')
+source=("https://nightly.link/dail8859/NotepadNext/actions/runs/8009956505/NotepadNext-Linux-Qt6.6-AppImage.zip")
+sha256sums=('7b3f0802f4a3dd16afcb66cbd71f1a1f62458003fae324ddc93c2e116d7ce652')
prepare() {
- # Extract the AppImage
+# Extract the AppImage
chmod +x "./NotepadNext-v$pkgver-x86_64.AppImage"
"./NotepadNext-v$pkgver-x86_64.AppImage" --appimage-extract
cd squashfs-root/usr/share/applications
- # Edit the shortcut
- sed -i -E "s|Icon=NotepadNext|Icon=$_pkgname|g" NotepadNext.desktop
- sed -i -E "s|Exec=NotepadNext %f|Exec=$_pkgname %f|g" NotepadNext.desktop
+# Edit the shortcut
+ sed -i -E "s|Icon=NotepadNext|Icon=notepadnext|g" NotepadNext.desktop
+ sed -i -E "s|Exec=NotepadNext %f|Exec=notepadnext %f|g" NotepadNext.desktop
sed -i -E "s|MimeType=text/plain;|MimeType=text/plain;application/x-yaml;application/xml;|g" NotepadNext.desktop
}
package() {
- # Create folders
+# Create directories
mkdir -p "$pkgdir/opt/NotepadNext" "$pkgdir/usr/bin"
- # Install
+# Install
cd squashfs-root
- install -Dm644 usr/share/icons/hicolor/scalable/apps/NotepadNext.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/$_pkgname.png"
- install -Dm644 usr/share/applications/NotepadNext.desktop "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ install -Dm644 usr/share/icons/hicolor/scalable/apps/NotepadNext.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/notepadnext.png"
+ install -Dm644 usr/share/applications/NotepadNext.desktop "$pkgdir/usr/share/applications/notepadnext.desktop"
mv usr/bin usr/lib usr/plugins "$pkgdir/opt/NotepadNext"
- ln -s /opt/NotepadNext/bin/NotepadNext "$pkgdir/usr/bin/$_pkgname"
+ ln -s /opt/NotepadNext/bin/NotepadNext "$pkgdir/usr/bin/notepadnext"
}