summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Molnar2022-12-16 00:07:18 +0100
committerRenato Molnar2022-12-16 00:15:03 +0100
commit2f46d52da6ecc014c8b50af1fddc368a78ecca3a (patch)
tree99fbaeba3aba4a9d1776d24c712222716180c1cc
parent95a1c3be3bb2c84d370faa77e75e187bd623ddd3 (diff)
downloadaur-2f46d52da6ecc014c8b50af1fddc368a78ecca3a.tar.gz
Rename package to notepad++
Bump version Simplify architecture selection Add PGP verification
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD69
-rw-r--r--notepad++ (renamed from notepadpp)35
-rw-r--r--notepad++.desktop (renamed from notepadpp.desktop)4
-rw-r--r--notepad++.png (renamed from notepadpp.png)bin70732 -> 70732 bytes
5 files changed, 89 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cf15bcfe68f..7870d4d57940 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = notepadpp
- pkgdesc = A free source code editor for Windows - (32-bit)
- pkgver = 8.4.4
- pkgrel = 2
+ pkgdesc = A free source code editor for Windows
+ pkgver = 8.4.7
+ pkgrel = 1
url = https://notepad-plus-plus.org/
arch = i686
arch = x86_64
@@ -11,20 +11,26 @@ pkgbase = notepadpp
depends = sh
depends = fuse-overlayfs
provides = notepadpp
- conflicts = notepadpp-win32
- conflicts = notepadpp-win64
- noextract = npp.8.4.4.32.zip
- noextract = npp.8.4.4.64.zip
+ replaces = notepadpp-win32
+ replaces = notepadpp-win64
+ replaces = notepadpp
+ noextract = npp.8.4.7.portable.zip
+ noextract = npp.8.4.7.portable.x64.zip
options = !strip
- source = notepadpp
- source = notepadpp.desktop
- source = notepadpp.png
- source = npp.8.4.4.32.zip::https://github.com/notepad-plus-plus/notepad-plus-plus/releases/download/v8.4.4/npp.8.4.4.portable.zip
- source = npp.8.4.4.64.zip::https://github.com/notepad-plus-plus/notepad-plus-plus/releases/download/v8.4.4/npp.8.4.4.portable.x64.zip
- sha256sums = 3e68329f18c46a240b8c852ccfe291b78ae0c37b692f090a1b2e379892415576
- sha256sums = a1c34d444893d56ae165c8457260e11b729ea2afc10bb9e2690bc89e1f523238
+ source = notepad++
+ source = notepad++.desktop
+ source = notepad++.png
+ source = https://github.com/notepad-plus-plus/notepad-plus-plus/releases/download/v8.4.7/npp.8.4.7.portable.zip
+ source = https://github.com/notepad-plus-plus/notepad-plus-plus/releases/download/v8.4.7/npp.8.4.7.portable.zip.sig
+ source = https://github.com/notepad-plus-plus/notepad-plus-plus/releases/download/v8.4.7/npp.8.4.7.portable.x64.zip
+ source = https://github.com/notepad-plus-plus/notepad-plus-plus/releases/download/v8.4.7/npp.8.4.7.portable.x64.zip.sig
+ validpgpkeys = 14BCE4362749B2B51F8C71226C429F1D8D84F46E
+ sha256sums = 643713113d26d32b2e6d861e9cd6db8153a3359f3784dbd1710f12e89468654a
+ sha256sums = 98693e0f57a9fab55dd31dfaf9b3a13234f14e1b193b56ac52eff33c987d4354
sha256sums = 04c8ad254a41350078bba4d56ad54f7b4c0df125029aee021ea0ac632971ebad
- sha256sums = b6c5c11518a7de1cb3ab095506ceb5a69520b19046e3e864cbfeee329fe8a250
- sha256sums = 2a07301ea6fe16cb7d814653239d80722b8b432313249720f6856aec070fded0
+ sha256sums = a294728c4d856bb93c075e86609210eebf2a5c8d0a8709f7553ed03bd7dbe5ac
+ sha256sums = SKIP
+ sha256sums = 4fa63354348015915df3a42b6750f676669a2743056daffd3b9358706c112000
+ sha256sums = SKIP
-pkgname = notepadpp
+pkgname = notepad++
diff --git a/PKGBUILD b/PKGBUILD
index b754c0ada072..b1aea7412b2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,54 @@
# Maintainer: Renato Molnar <renato dot molnar at posteo dot net>
-# If you want to package the 64bit version, you need to uncomment the following line:
-#_arch=x64
-
-if [[ "${_arch}" == x64 ]]; then
- winarch='64'
-else
- winarch='32'
-fi
-
-pkgname=notepadpp
+# Use the following variable to change package architecture.
+# To use OS architecture please uncomment it
+_arch="x86"
+# possible values: "x86", "x64"
+
+case "${_arch-"${CARCH}"}" in
+ i686|x86)
+ _archstr='';;
+ x86_64|x64)
+ _archstr='.x64';;
+esac
+
+pkgbase=notepadpp
+pkgname=notepad++
_pkgname=notepad-plus-plus
-pkgver=8.4.4
-pkgrel=2
-pkgdesc="A free source code editor for Windows - (${winarch}-bit)"
-arch=('x86_64')
+pkgver=8.4.7
+pkgrel=1
+pkgdesc="A free source code editor for Windows"
url="https://${_pkgname}.org/"
license=('GPL2')
arch=('i686' 'x86_64')
depends=('wine' 'sh' 'fuse-overlayfs')
makedepends=('unzip')
provides=(notepadpp)
-conflicts=('notepadpp-win32' 'notepadpp-win64')
-source=(notepadpp
- notepadpp.desktop
- notepadpp.png
- "npp.${pkgver}.32.zip::https://github.com/${_pkgname}/${_pkgname}/releases/download/v${pkgver}/npp.${pkgver}.portable.zip"
- "npp.${pkgver}.64.zip::https://github.com/${_pkgname}/${_pkgname}/releases/download/v${pkgver}/npp.${pkgver}.portable.x64.zip")
-
-sha256sums=('3e68329f18c46a240b8c852ccfe291b78ae0c37b692f090a1b2e379892415576'
- 'a1c34d444893d56ae165c8457260e11b729ea2afc10bb9e2690bc89e1f523238'
+replaces=('notepadpp-win32' 'notepadpp-win64' 'notepadpp')
+source=(notepad++
+ notepad++.desktop
+ notepad++.png
+ "https://github.com/${_pkgname}/${_pkgname}/releases/download/v${pkgver}/npp.${pkgver}.portable.zip"{,.sig}
+ "https://github.com/${_pkgname}/${_pkgname}/releases/download/v${pkgver}/npp.${pkgver}.portable.x64.zip"{,.sig})
+sha256sums=('643713113d26d32b2e6d861e9cd6db8153a3359f3784dbd1710f12e89468654a'
+ '98693e0f57a9fab55dd31dfaf9b3a13234f14e1b193b56ac52eff33c987d4354'
'04c8ad254a41350078bba4d56ad54f7b4c0df125029aee021ea0ac632971ebad'
- 'b6c5c11518a7de1cb3ab095506ceb5a69520b19046e3e864cbfeee329fe8a250'
- '2a07301ea6fe16cb7d814653239d80722b8b432313249720f6856aec070fded0')
+ 'a294728c4d856bb93c075e86609210eebf2a5c8d0a8709f7553ed03bd7dbe5ac'
+ 'SKIP'
+ '4fa63354348015915df3a42b6750f676669a2743056daffd3b9358706c112000'
+ 'SKIP')
-noextract=("npp.${pkgver}.32.zip"
- "npp.${pkgver}.64.zip")
+noextract=("npp.${pkgver}.portable.zip"
+ "npp.${pkgver}.portable.x64.zip")
+
+validpgpkeys=('14BCE4362749B2B51F8C71226C429F1D8D84F46E')
options=('!strip')
package() {
-
install -d -m755 "${pkgdir}/usr/share/${pkgname}"
- unzip "${srcdir}/npp.${pkgver}.${winarch}.zip" -d "${pkgdir}/usr/share/${pkgname}"
+ unzip "${srcdir}/npp.${pkgver}.portable${_archstr}.zip" -d "${pkgdir}/usr/share/${pkgname}"
rm -rf "${pkgdir}/usr/share/${pkgname}/updater" \
"${pkgdir}/usr/share/${pkgname}/license.txt" \
@@ -51,8 +56,8 @@ package() {
find "${pkgdir}/usr/share/${pkgname}" -type d -exec chmod 755 "{}" \;
find "${pkgdir}/usr/share/${pkgname}" -type f -exec chmod 644 "{}" \;
- install -D -m755 "${srcdir}/notepadpp" "${pkgdir}/usr/bin/notepadpp"
- install -D -m644 "${srcdir}/notepadpp.png" "${pkgdir}/usr/share/pixmaps/notepadpp.png"
- install -D -m644 "${srcdir}/notepadpp.desktop" "${pkgdir}/usr/share/applications/notepadpp.desktop"
+ install -D -m755 "${srcdir}/notepad++" "${pkgdir}/usr/bin/notepad++"
+ install -D -m644 "${srcdir}/notepad++.png" "${pkgdir}/usr/share/pixmaps/notepad++.png"
+ install -D -m644 "${srcdir}/notepad++.desktop" "${pkgdir}/usr/share/applications/notepad++.desktop"
}
diff --git a/notepadpp b/notepad++
index fda1e16e922c..733befb112a3 100644
--- a/notepadpp
+++ b/notepad++
@@ -1,20 +1,39 @@
#!/usr/bin/env sh
# vim: syntax=sh
-if [ -n "${SH_TRACE}" ]; then
+if [ "${SH_TRACE-0}" -eq 1 ]; then
# shellcheck disable=2016
PS4="$(printf '%b%s%b:\n' '\033[31m' 'L${LINENO}' '\033[0m')"
export PS4
set -x
fi
-readonly appName='notepadpp'
-readonly exeName='notepad++.exe'
+appName='notepad++'
+exeName="${appName}.exe"
-readonly pkgDir="/usr/share/${appName}"
-readonly localDir="${HOME}/.local/share/${appName}"
-readonly configDir="${HOME}/.config/${appName}"
-readonly cacheDir="${HOME}/.cache/${appName}"
+readonly appName exeName
+
+pkgDir="/usr/share/${appName}"
+localDir="${HOME}/.local/share/${appName}"
+configDir="${HOME}/.config/${appName}"
+cacheDir="${HOME}/.cache/${appName}"
+
+readonly pkgDir localDir configDir cacheDir
+
+(
+ oldAppName='notepadpp'
+ oldConfigDir="${HOME}/.config/${oldAppName}"
+ readonly oldAppName oldConfigDir
+ if [ -d "${oldConfigDir}" ]; then
+ printf 'Old configdir found. Renaming...'
+ mv -v "${oldConfigDir}" "${configDir}"
+ fi
+)
+
+if [ ! -d "${pkgDir}" ]; then
+ printf 'Cannot find application directory: %s\n' >&2 "${pkgDir}"
+ exit 1
+fi
# shellcheck disable=2155
readonly uid="$(id -u)"
@@ -44,7 +63,7 @@ if ! fuse-overlayfs -o squash_to_uid="${uid}" -o squash_to_gid="${gid}" \
-o lowerdir="${pkgDir}" -o upperdir="${configDir}" -o workdir="${cacheDir}" \
"${localDir}"; then
print 'Mount failed: cannot mount fuse-overlayfs\n' >&2
- exit 1
+ exit 2
fi
trap 'cleanup' INT TERM EXIT
diff --git a/notepadpp.desktop b/notepad++.desktop
index a00237587dce..854ce92ddd83 100644
--- a/notepadpp.desktop
+++ b/notepad++.desktop
@@ -3,8 +3,8 @@ Encoding=UTF-8
Categories=Programming,Utilities
Name=Notepad++
Comment=The free source code editor
-Icon=notepadpp
-Exec=notepadpp
+Icon=notepad++
+Exec=notepad++
Terminal=false
Type=Application
diff --git a/notepadpp.png b/notepad++.png
index 2e4bcb31975c..2e4bcb31975c 100644
--- a/notepadpp.png
+++ b/notepad++.png
Binary files differ