summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Molnar2021-07-25 22:49:34 +0200
committerRenato Molnar2021-07-25 22:49:34 +0200
commit9650e695edcdb2cd9097cddf09309f498e55756f (patch)
tree8532ae3efda004f21da4e8d6b0c15c9df17c1ecd
parent1f88b54abf0439b6c9d2e8356bf1f58c8bca3201 (diff)
downloadaur-9650e695edcdb2cd9097cddf09309f498e55756f.tar.gz
Bump version to 8.1.2; Fix "wine: failed to open" bug
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
-rw-r--r--notepadpp7
3 files changed, 23 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d85ec92f32cf..ac705048b21d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = notepadpp
pkgdesc = A free source code editor for Windows (32-bit)
- pkgver = 8.1
+ pkgver = 8.1.2
pkgrel = 1
url = https://notepad-plus-plus.org/
arch = i686
@@ -13,18 +13,18 @@ pkgbase = notepadpp
provides = notepadpp
conflicts = notepadpp-win32
conflicts = notepadpp-win64
- noextract = npp.8.1.bin.zip
- noextract = npp.8.1.bin.x64.zip
+ noextract = npp.8.1.2.bin.zip
+ noextract = npp.8.1.2.bin.x64.zip
options = !strip
source = notepadpp
source = notepadpp.desktop
source = notepadpp.png
- source = https://github.com/notepad-plus-plus/notepad-plus-plus/releases/download/v8.1/npp.8.1.portable.zip
- source = https://github.com/notepad-plus-plus/notepad-plus-plus/releases/download/v8.1/npp.8.1.portable.x64.zip
- sha256sums = baefda04b95342db657df7f650fb5d6dd43e966a2158a0ebb5837129f8755379
+ source = https://github.com/notepad-plus-plus/notepad-plus-plus/releases/download/v8.1.2/npp.8.1.2.portable.zip
+ source = https://github.com/notepad-plus-plus/notepad-plus-plus/releases/download/v8.1.2/npp.8.1.2.portable.x64.zip
+ sha256sums = d4352139a459f532b807262b5b1933c98142fc772de713abc39e6073d291b200
sha256sums = a1c34d444893d56ae165c8457260e11b729ea2afc10bb9e2690bc89e1f523238
sha256sums = 04c8ad254a41350078bba4d56ad54f7b4c0df125029aee021ea0ac632971ebad
- sha256sums = 284767275495aea43848c0c3cf006377efc39552133fb3c646ce2690ddad796b
- sha256sums = dcff12dcd03f71aea5f32e8da6048d903fdec199af71dfd2d5590d3f586db5be
+ sha256sums = e10c1cb87c3c1fb3d69eba24edccd4d261968edc2f5a5c3e9caf5d237124bdae
+ sha256sums = 3e9a8ec74f2c41478b1b3212b44603bdab08e993fe9be5cc4d0fc443d7e8e42d
pkgname = notepadpp
diff --git a/PKGBUILD b/PKGBUILD
index c523ea136aec..97fd143f1c4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=notepadpp
_pkgname=notepad-plus-plus
-pkgver=8.1
+pkgver=8.1.2
pkgrel=1
pkgdesc="A free source code editor for Windows"
arch=('x86_64')
@@ -21,11 +21,11 @@ source=(notepadpp
"https://github.com/${_pkgname}/${_pkgname}/releases/download/v${pkgver}/npp.${pkgver}.portable.zip"
"https://github.com/${_pkgname}/${_pkgname}/releases/download/v${pkgver}/npp.${pkgver}.portable.x64.zip")
-sha256sums=('baefda04b95342db657df7f650fb5d6dd43e966a2158a0ebb5837129f8755379'
+sha256sums=('d4352139a459f532b807262b5b1933c98142fc772de713abc39e6073d291b200'
'a1c34d444893d56ae165c8457260e11b729ea2afc10bb9e2690bc89e1f523238'
'04c8ad254a41350078bba4d56ad54f7b4c0df125029aee021ea0ac632971ebad'
- '284767275495aea43848c0c3cf006377efc39552133fb3c646ce2690ddad796b'
- 'dcff12dcd03f71aea5f32e8da6048d903fdec199af71dfd2d5590d3f586db5be')
+ 'e10c1cb87c3c1fb3d69eba24edccd4d261968edc2f5a5c3e9caf5d237124bdae'
+ '3e9a8ec74f2c41478b1b3212b44603bdab08e993fe9be5cc4d0fc443d7e8e42d')
noextract=("npp.${pkgver}.bin.zip"
"npp.${pkgver}.bin.x64.zip")
@@ -42,17 +42,15 @@ options=('!strip')
package() {
- install -d -m755 "${pkgdir}/usr/share/${pkgbase}"
+ install -d -m755 "${pkgdir}/usr/share/${pkgname}"
- unzip "${srcdir}/npp.${pkgver}.portable${_arch}.zip" -d "${pkgdir}/usr/share/${pkgbase}"
+ unzip "${srcdir}/npp.${pkgver}.portable${_arch}.zip" -d "${pkgdir}/usr/share/${pkgname}"
- rm -rf "${pkgdir}/usr/share/${pkgbase}/updater" \
- "${pkgdir}/usr/share/${pkgbase}/license.txt" \
+ rm -rf "${pkgdir}/usr/share/${pkgname}/updater" \
+ "${pkgdir}/usr/share/${pkgname}/license.txt" \
- find "${pkgdir}/usr/share/${pkgbase}" -type d -exec chmod 755 "{}" \;
- find "${pkgdir}/usr/share/${pkgbase}" -type f -exec chmod 644 "{}" \;
-
- ln -s "/usr/share/${pkgbase}/notepad++.exe" "${pkgdir}/usr/share/${pkgbase}/notepadpp.exe"
+ find "${pkgdir}/usr/share/${pkgname}" -type d -exec chmod 755 "{}" \;
+ find "${pkgdir}/usr/share/${pkgname}" -type f -exec chmod 644 "{}" \;
install -D -m755 "${srcdir}/notepadpp" "${pkgdir}/usr/bin/notepadpp"
install -D -m644 "${srcdir}/notepadpp.png" "${pkgdir}/usr/share/pixmaps/notepadpp.png"
diff --git a/notepadpp b/notepadpp
index d3ce6b11b246..0b88812ef070 100644
--- a/notepadpp
+++ b/notepadpp
@@ -1,6 +1,7 @@
#!/usr/bin/env sh
app_name='notepadpp'
+exe_name='notepad++.exe'
pkgdir="/usr/share/${app_name}"
localdir="${HOME}/.local/share/${app_name}"
@@ -14,7 +15,9 @@ for folder in "${localdir}" "${cachedir}" "${configdir}"; do
done
cleanup() {
- umount "${localdir}"
+ until umount "${localdir}"; do
+ sleep 5
+ done
}
if mount | grep -q "${localdir}"; then
@@ -33,4 +36,4 @@ if [ -n "${1}" ]; then
fi
unset WINEPREFIX
-WINEDLLOVERRIDES="${WINEDLLOVERRIDES};mscoree=d;mshtml=d" WINEDEBUG=-all wine "${localdir}/${app_name}" "${argpath}"
+WINEDLLOVERRIDES="${WINEDLLOVERRIDES};mscoree=d;mshtml=d" WINEDEBUG=-all wine "${localdir}/${exe_name}" "${argpath}"