summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Molnar2021-02-01 00:50:24 +0100
committerRenato Molnar2021-02-01 00:50:24 +0100
commit9787e55c095cb1a929edc143fe741c84138bbc6b (patch)
tree6a7212ceef2c73d5691dff2cc8eef192ea9119cb
parent642fd8169b31b4cdba96e45f4abb4d098d443654 (diff)
downloadaur-9787e55c095cb1a929edc143fe741c84138bbc6b.tar.gz
Bump version to 7.9.2
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD8
-rw-r--r--notepadpp18
4 files changed, 26 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2bd478ecda2..41ecda70d6ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = notepadpp
pkgdesc = A free source code editor for Windows (32-bit)
- pkgver = 7.9
+ pkgver = 7.9.2
pkgrel = 1
url = https://notepad-plus-plus.org/
arch = i686
@@ -13,19 +13,19 @@ pkgbase = notepadpp
provides = notepadpp
conflicts = notepadpp-win32
conflicts = notepadpp-win64
- noextract = npp.7.9.bin.zip
- noextract = npp.7.9.bin.x64.zip
+ noextract = npp.7.9.2.bin.zip
+ noextract = npp.7.9.2.bin.x64.zip
options = !strip
source = notepadpp
source = notepadpp.desktop
source = notepadpp.png
- source = https://github.com/notepad-plus-plus/notepad-plus-plus/releases/download/v7.9/npp.7.9.portable.zip
- source = https://github.com/notepad-plus-plus/notepad-plus-plus/releases/download/v7.9/npp.7.9.portable.x64.zip
- sha256sums = a104f9759db9b2ae95577f2576a5257ffaf4a6beef366d2e0de64d10b6d114ec
+ source = https://github.com/notepad-plus-plus/notepad-plus-plus/releases/download/v7.9.2/npp.7.9.2.portable.zip
+ source = https://github.com/notepad-plus-plus/notepad-plus-plus/releases/download/v7.9.2/npp.7.9.2.portable.x64.zip
+ sha256sums = baefda04b95342db657df7f650fb5d6dd43e966a2158a0ebb5837129f8755379
sha256sums = a1c34d444893d56ae165c8457260e11b729ea2afc10bb9e2690bc89e1f523238
sha256sums = 04c8ad254a41350078bba4d56ad54f7b4c0df125029aee021ea0ac632971ebad
- sha256sums = 22dd3d1d30b4a75717207206d568ff0654430ccb6fa18c3faeb94692a7020e2a
- sha256sums = 126b4cdab094639696ffa92f2e544b8ba8487333175e1b729ba1a2682406f65a
+ sha256sums = 1f20b7fde2a8b98924df098b21ca7ffe00226c5f60f271bf615218ac0a78b420
+ sha256sums = 15f3b2c2f3b99f69d4fce338d57a6708f31206ed5eb300875002be2c6dd119e0
pkgname = notepadpp
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5d59227d0145
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.log
+npp.*.zip
diff --git a/PKGBUILD b/PKGBUILD
index e00d8d409611..9a64a77f3dcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=notepadpp
_pkgname=notepad-plus-plus
-pkgver=7.9
+pkgver=7.9.2
pkgrel=1
pkgdesc="A free source code editor for Windows"
arch=('x86_64')
@@ -21,11 +21,11 @@ source=(notepadpp
"https://github.com/${_pkgname}/${_pkgname}/releases/download/v${pkgver}/npp.${pkgver}.portable.zip"
"https://github.com/${_pkgname}/${_pkgname}/releases/download/v${pkgver}/npp.${pkgver}.portable.x64.zip")
-sha256sums=('a104f9759db9b2ae95577f2576a5257ffaf4a6beef366d2e0de64d10b6d114ec'
+sha256sums=('baefda04b95342db657df7f650fb5d6dd43e966a2158a0ebb5837129f8755379'
'a1c34d444893d56ae165c8457260e11b729ea2afc10bb9e2690bc89e1f523238'
'04c8ad254a41350078bba4d56ad54f7b4c0df125029aee021ea0ac632971ebad'
- '22dd3d1d30b4a75717207206d568ff0654430ccb6fa18c3faeb94692a7020e2a'
- '126b4cdab094639696ffa92f2e544b8ba8487333175e1b729ba1a2682406f65a')
+ '1f20b7fde2a8b98924df098b21ca7ffe00226c5f60f271bf615218ac0a78b420'
+ '15f3b2c2f3b99f69d4fce338d57a6708f31206ed5eb300875002be2c6dd119e0')
noextract=("npp.${pkgver}.bin.zip"
"npp.${pkgver}.bin.x64.zip")
diff --git a/notepadpp b/notepadpp
index 723c5e9b8147..d3ce6b11b246 100644
--- a/notepadpp
+++ b/notepadpp
@@ -7,24 +7,30 @@ localdir="${HOME}/.local/share/${app_name}"
configdir="${HOME}/.config/${app_name}"
cachedir="${HOME}/.cache/${app_name}"
-unset WINEPREFIX
-
for folder in "${localdir}" "${cachedir}" "${configdir}"; do
if [ ! -d "${folder}" ]; then
mkdir -p "${folder}"
fi
done
+cleanup() {
+ umount "${localdir}"
+}
+
if mount | grep -q "${localdir}"; then
- echo "${app_name} already mounted"
-elif ! fuse-overlayfs -o lowerdir="${pkgdir}" -o upperdir="${configdir}" -o workdir="${cachedir}" "${localdir}"; then
+ cleanup
+fi
+
+if ! fuse-overlayfs -o lowerdir="${pkgdir}" -o upperdir="${configdir}" -o workdir="${cachedir}" "${localdir}"; then
echo "ERROR: cannot mount fuse-overlayfs for ${app_name}"
exit 1
fi
+trap 'cleanup' INT TERM EXIT
+
if [ -n "${1}" ]; then
argpath="Z:\\$(readlink -f "${1}" | sed 's|/|\\\\|g')"
fi
-WINEDEBUG=-all exec wine "${localdir}/${app_name}" "${args}${argpath}"
-
+unset WINEPREFIX
+WINEDLLOVERRIDES="${WINEDLLOVERRIDES};mscoree=d;mshtml=d" WINEDEBUG=-all wine "${localdir}/${app_name}" "${argpath}"