summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Molnar2022-02-13 21:37:20 +0100
committerRenato Molnar2022-02-13 21:37:20 +0100
commitdd0f408757cba20ca0467a15684d02a35995f6bb (patch)
treeac4f8183142976fc8f2b38f4300b70df6de375a6
parent9650e695edcdb2cd9097cddf09309f498e55756f (diff)
downloadaur-dd0f408757cba20ca0467a15684d02a35995f6bb.tar.gz
Bump version to 8.3
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD11
3 files changed, 26 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac705048b21d..dc361cd44dab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = notepadpp
pkgdesc = A free source code editor for Windows (32-bit)
- pkgver = 8.1.2
+ pkgver = 8.3
pkgrel = 1
url = https://notepad-plus-plus.org/
arch = i686
@@ -13,18 +13,18 @@ pkgbase = notepadpp
provides = notepadpp
conflicts = notepadpp-win32
conflicts = notepadpp-win64
- noextract = npp.8.1.2.bin.zip
- noextract = npp.8.1.2.bin.x64.zip
+ noextract = npp.8.3.bin.zip
+ noextract = npp.8.3.bin.x64.zip
options = !strip
source = notepadpp
source = notepadpp.desktop
source = notepadpp.png
- source = https://github.com/notepad-plus-plus/notepad-plus-plus/releases/download/v8.1.2/npp.8.1.2.portable.zip
- source = https://github.com/notepad-plus-plus/notepad-plus-plus/releases/download/v8.1.2/npp.8.1.2.portable.x64.zip
+ source = https://github.com/notepad-plus-plus/notepad-plus-plus/releases/download/v8.3/npp.8.3.portable.zip
+ source = https://github.com/notepad-plus-plus/notepad-plus-plus/releases/download/v8.3/npp.8.3.portable.x64.zip
sha256sums = d4352139a459f532b807262b5b1933c98142fc772de713abc39e6073d291b200
sha256sums = a1c34d444893d56ae165c8457260e11b729ea2afc10bb9e2690bc89e1f523238
sha256sums = 04c8ad254a41350078bba4d56ad54f7b4c0df125029aee021ea0ac632971ebad
- sha256sums = e10c1cb87c3c1fb3d69eba24edccd4d261968edc2f5a5c3e9caf5d237124bdae
- sha256sums = 3e9a8ec74f2c41478b1b3212b44603bdab08e993fe9be5cc4d0fc443d7e8e42d
+ sha256sums = 0457ccbc82978a917944283fdad7416bf6ed9d7e5dd37c5b02404168a8bad745
+ sha256sums = 1a5c01fc3fbb0f0a99daef7ca25b8c6aa30f34bd52e1ac9f645c189efc173e53
pkgname = notepadpp
diff --git a/.gitignore b/.gitignore
index 5d59227d0145..fcd8849c9111 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,14 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.txz
*.log
-npp.*.zip
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 97fd143f1c4f..cf3314eb7fc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,8 @@
# Maintainer: Renato Molnar <m dot renato93 at gmail dot com>
-#_arch=x64
-
pkgname=notepadpp
_pkgname=notepad-plus-plus
-pkgver=8.1.2
+pkgver=8.3
pkgrel=1
pkgdesc="A free source code editor for Windows"
arch=('x86_64')
@@ -24,12 +22,15 @@ source=(notepadpp
sha256sums=('d4352139a459f532b807262b5b1933c98142fc772de713abc39e6073d291b200'
'a1c34d444893d56ae165c8457260e11b729ea2afc10bb9e2690bc89e1f523238'
'04c8ad254a41350078bba4d56ad54f7b4c0df125029aee021ea0ac632971ebad'
- 'e10c1cb87c3c1fb3d69eba24edccd4d261968edc2f5a5c3e9caf5d237124bdae'
- '3e9a8ec74f2c41478b1b3212b44603bdab08e993fe9be5cc4d0fc443d7e8e42d')
+ '0457ccbc82978a917944283fdad7416bf6ed9d7e5dd37c5b02404168a8bad745'
+ '1a5c01fc3fbb0f0a99daef7ca25b8c6aa30f34bd52e1ac9f645c189efc173e53')
noextract=("npp.${pkgver}.bin.zip"
"npp.${pkgver}.bin.x64.zip")
+# If you want to package the 64bit version, you need to uncomment the following line:
+#_arch=x64
+
if [[ "${_arch}" == x64 ]]; then
_arch='.x64'
pkgdesc+=" (64-bit)"