summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2022-09-24 20:35:26 -0400
committerChris Severance2022-09-24 20:35:26 -0400
commit76e44d88a7f4c3eb7000626cafbb4aeba8e23610 (patch)
treea82e0c7512285bd92263a6ed685bb06854fc4b19
parent0650c06bf2b2fbcc8cc5ae0c34077fd3cf8ea39e (diff)
downloadaur-76e44d88a7f4c3eb7000626cafbb4aeba8e23610.tar.gz
autu: Update to 2.0.0.beta.r12.gd8000f25-1 github https
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
2 files changed, 15 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cda692a6df8..fc0db6a77c31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = notepadqq-git
pkgdesc = Notepad++-like text editor for Linux
- pkgver = 2.0.0.beta.r5.g5553c0be
+ pkgver = 2.0.0.beta.r12.gd8000f25
pkgrel = 1
url = https://notepadqq.com/
arch = x86_64
@@ -10,22 +10,22 @@ pkgbase = notepadqq-git
makedepends = qt5-tools
makedepends = qt5-websockets
makedepends = qt5-tools>=5.6
- depends = qt5-svg>=5.6
depends = hicolor-icon-theme
- depends = qt5-svg
+ depends = qt5-svg>=5.6
depends = qt5-webkit
+ depends = desktop-file-utils
depends = qt5-webengine>=5.6
depends = uchardet
+ optdepends = mathjax2: Math rendering
provides = notepadqq=2.0.0.beta
conflicts = notepadqq
options = !emptydirs
options = !strip
- source = git://github.com/notepadqq/notepadqq.git
- source = git://github.com/notepadqq/CodeMirror.git
+ source = git+https://github.com/notepadqq/notepadqq.git
+ source = git+https://github.com/notepadqq/CodeMirror.git
md5sums = SKIP
md5sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
pkgname = notepadqq-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 538e958ae951..fb53533684aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
set -u
pkgname=notepadqq
pkgname+='-git'
-pkgver=2.0.0.beta.r5.g5553c0be
+pkgver=2.0.0.beta.r12.gd8000f25
pkgrel=1
pkgdesc='Notepad++-like text editor for Linux'
arch=('x86_64')
@@ -12,11 +12,13 @@ arch+=('i686')
#url='http://notepadqq.altervista.org/wp/'
url='https://notepadqq.com/'
license=('GPL3')
-depends=('desktop-file-utils' 'hicolor-icon-theme' 'qt5-svg' 'qt5-webkit')
-depends[0]='qt5-svg>=5.6'
+depends=('hicolor-icon-theme' 'qt5-svg' 'qt5-webkit')
+depends+=('desktop-file-utils')
+depends[1]='qt5-svg>=5.6'
depends+=('qt5-webengine>=5.6' 'uchardet')
makedepends=('git' 'qt5-tools')
makedepends+=('qt5-websockets' 'qt5-tools>=5.6')
+optdepends=('mathjax2: Math rendering')
options=('!emptydirs')
options+=('!strip')
provides=("notepadqq=${pkgver%%.r*}")
@@ -24,8 +26,8 @@ conflicts=('notepadqq') # 'notepadqq-bin' 'notepadqq-common' 'notepadqq-src'
#install="${pkgname#-git}.install"
_srcdir="${pkgname%-git}"
source=(
- 'git://github.com/notepadqq/notepadqq.git'
- 'git://github.com/notepadqq/CodeMirror.git'
+ 'git+https://github.com/notepadqq/notepadqq.git'
+ 'git+https://github.com/notepadqq/CodeMirror.git'
)
md5sums=('SKIP'
'SKIP')
@@ -36,7 +38,7 @@ pkgver() {
set -u
cd "${_srcdir}"
set -o pipefail
- if ! git describe --long | sed -e 's/^v//' -e 's/\([^-]*-g\)/r\1/' -e 's/-/./g'; then
+ if ! git describe --long | sed -e 's/^v//' -e 's/[^-]*-g/r&/' -e 's/-/./g'; then
printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
fi
set +u
@@ -55,17 +57,8 @@ prepare() {
build() {
set -u
cd "${_srcdir}"
-
qmake-qt5 PREFIX=/usr LRELEASE=/usr/bin/lrelease notepadqq.pro
-
- if [ -z "${MAKEFLAGS:=}" ] || [ "${MAKEFLAGS//-j/}" = "${MAKEFLAGS}" ]; then
- local _nproc="$(nproc)"
- if [ "${_nproc}" -gt 8 ]; then
- _nproc=8
- fi
- _mflags+=('-j' "${_nproc}")
- fi
- nice make -s "${_mflags[@]}"
+ nice make -s
set +u
}