summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgbr2023-05-01 19:01:44 -0300
committergbr2023-05-01 19:01:44 -0300
commit0b1083dfa4b5aa708c8b5e1297bb73ad13e48e7b (patch)
treedb30e3ce34a30103c89a8980c9be7a52073214cf
parentd37d6ec5516f7f73f1b4d9f264b75a8f0b6fb310 (diff)
downloadaur-0b1083dfa4b5aa708c8b5e1297bb73ad13e48e7b.tar.gz
notes-git 2.1.0.r54.geecd263-1
NOTE: The upstream project for this AUR package has been changed. Before: https://github.com/pimterry/notes Now: https://github.com/nuttyartist/notes
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD62
3 files changed, 62 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc138444f80d..35f3c868de23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,24 @@
pkgbase = notes-git
- pkgdesc = Simple delightful note taking, with more unix and less lock-in.
- pkgver = 0.5.0.r6.ge3a9eab
+ pkgdesc = Note taking application, write down your thoughts
+ pkgver = 2.1.0.r54.geecd263
pkgrel = 1
- url = https://github.com/pimterry/notes
- arch = any
- license = MIT
+ url = https://github.com/nuttyartist/notes
+ arch = x86_64
+ license = MPL
+ makedepends = cmake
makedepends = git
- depends = bash
+ depends = hicolor-icon-theme
+ depends = qt6-base
+ depends = qt6-declarative
provides = notes
- source = git+https://github.com/pimterry/notes.git
- md5sums = SKIP
+ conflicts = notes
+ source = git+https://github.com/nuttyartist/notes.git
+ source = git+https://github.com/b00f/qautostart.git
+ source = git+https://github.com/pbek/qmarkdowntextedit.git
+ source = git+https://github.com/alex-spataru/QSimpleUpdater.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = notes-git
-
diff --git a/.gitignore b/.gitignore
index 4cad3c0ef9c2..19a61973d30c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,6 @@
+qautostart
+qmarkdowntextedit
+QSimpleUpdater
notes
pkg
src
diff --git a/PKGBUILD b/PKGBUILD
index 11f09eeecc6c..f1538ae6982a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,51 @@
-# Maintainer: Jacob Mischka <jacob@mischka.me>
-# Maintainer: Brokenpip3 <brokenpip3[at]gmail[dot]com>
+# Maintainer: gbr <gbr at pm dot me>
+_pkgname=notes
pkgname=notes-git
-pkgver=0.5.0.r6.ge3a9eab
+pkgver=2.1.0.r54.geecd263
pkgrel=1
-pkgdesc="Simple delightful note taking, with more unix and less lock-in."
-arch=('any')
-url="https://github.com/pimterry/notes"
-license=('MIT')
-depends=('bash')
-makedepends=('git')
+pkgdesc='Note taking application, write down your thoughts'
+arch=('x86_64')
+url='https://github.com/nuttyartist/notes'
+license=('MPL')
+makedepends=('cmake' 'git')
+depends=('hicolor-icon-theme' 'qt6-base' 'qt6-declarative')
provides=('notes')
-source=('git+https://github.com/pimterry/notes.git')
-md5sums=('SKIP')
-
-_pkgname=notes
+conflicts=('notes')
+source=('git+https://github.com/nuttyartist/notes.git'
+ 'git+https://github.com/b00f/qautostart.git'
+ 'git+https://github.com/pbek/qmarkdowntextedit.git'
+ 'git+https://github.com/alex-spataru/QSimpleUpdater.git')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${_pkgname}"
+ git describe --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${_pkgname}"
+ git submodule init
+ git submodule set-url 3rdParty/qautostart "${srcdir}/qautostart"
+ git submodule set-url 3rdParty/qmarkdowntextedit "${srcdir}/qmarkdowntextedit"
+ git submodule set-url 3rdParty/QSimpleUpdater "${srcdir}/QSimpleUpdater"
+ git -c protocol.file.allow=always submodule update
+}
+
+build() {
+ cd "${_pkgname}"
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_QT_VERSION=6 \
+ -DUPDATE_CHECKER=OFF
+ cmake --build build
}
package() {
- cd "$srcdir/$_pkgname"
- install -D ${_pkgname} "${pkgdir}/usr/bin/${_pkgname}"
- install -Dm644 ${_pkgname}.bash_completion "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}"
- install -Dm644 ${_pkgname}.1 "${pkgdir}/usr/share/man/man1/${_pkgname}.1"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
- install -Dm644 config "${pkgdir}/usr/share/${_pkgname}/config.example"
+ cd "${_pkgname}"
+ DESTDIR="${pkgdir}" cmake --install build
}