summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrokenpip32019-09-22 20:03:55 +0200
committerbrokenpip32019-09-22 20:03:55 +0200
commitd37d6ec5516f7f73f1b4d9f264b75a8f0b6fb310 (patch)
tree4827faec56d90932c9de62b90511dcf23d7eda8c
parenteda1ef0246be232aad1efbfc9f71f38e361a44cf (diff)
downloadaur-d37d6ec5516f7f73f1b4d9f264b75a8f0b6fb310.tar.gz
Update:
* Add pkgver * Add bash completion * Add man page * Add config example file
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b038c431069b..cc138444f80d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
-# Generated by mksrcinfo v8
-# Sat Dec 3 04:04:18 UTC 2016
pkgbase = notes-git
pkgdesc = Simple delightful note taking, with more unix and less lock-in.
- pkgver = 20161202
+ pkgver = 0.5.0.r6.ge3a9eab
pkgrel = 1
url = https://github.com/pimterry/notes
arch = any
license = MIT
makedepends = git
+ depends = bash
provides = notes
source = git+https://github.com/pimterry/notes.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 9021d01c24f6..11f09eeecc6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,31 @@
# Maintainer: Jacob Mischka <jacob@mischka.me>
+# Maintainer: Brokenpip3 <brokenpip3[at]gmail[dot]com>
+
pkgname=notes-git
-pkgver=20161202
+pkgver=0.5.0.r6.ge3a9eab
pkgrel=1
pkgdesc="Simple delightful note taking, with more unix and less lock-in."
arch=('any')
url="https://github.com/pimterry/notes"
license=('MIT')
-depends=()
+depends=('bash')
makedepends=('git')
provides=('notes')
source=('git+https://github.com/pimterry/notes.git')
md5sums=('SKIP')
-_gitroot=notes
+_pkgname=notes
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
package() {
- cd "$srcdir/$_gitroot"
- install -D notes "$pkgdir/usr/bin/notes"
+ cd "$srcdir/$_pkgname"
+ install -D ${_pkgname} "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 ${_pkgname}.bash_completion "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}"
+ install -Dm644 ${_pkgname}.1 "${pkgdir}/usr/share/man/man1/${_pkgname}.1"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm644 config "${pkgdir}/usr/share/${_pkgname}/config.example"
}