summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzjeffer2023-06-10 22:38:04 +0200
committerzjeffer2023-06-10 22:41:22 +0200
commite365995ba522caf0597fc42152d51ff47875d33f (patch)
tree3d5542ae2cfa65474a2fbcdf2ed8eb44626a4d1b
parent0b1083dfa4b5aa708c8b5e1297bb73ad13e48e7b (diff)
downloadaur-e365995ba522caf0597fc42152d51ff47875d33f.tar.gz
Attempt to fix automatic updating to latest git commit
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD52
2 files changed, 28 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35f3c868de23..e8dff1de3a91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = notes-git
pkgdesc = Note taking application, write down your thoughts
- pkgver = 2.1.0.r54.geecd263
+ pkgver = 2.1.0.r74.g5b76489
pkgrel = 1
url = https://github.com/nuttyartist/notes
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = notes-git
depends = qt6-declarative
provides = notes
conflicts = notes
- source = git+https://github.com/nuttyartist/notes.git
+ source = notes-git::git+https://github.com/nuttyartist/notes
source = git+https://github.com/b00f/qautostart.git
source = git+https://github.com/pbek/qmarkdowntextedit.git
source = git+https://github.com/alex-spataru/QSimpleUpdater.git
diff --git a/PKGBUILD b/PKGBUILD
index f1538ae6982a..02348c51790e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname=notes
pkgname=notes-git
-pkgver=2.1.0.r54.geecd263
-pkgrel=1
+pkgver=2.1.0.r74.g5b76489
+pkgrel=2
pkgdesc='Note taking application, write down your thoughts'
arch=('x86_64')
url='https://github.com/nuttyartist/notes'
@@ -12,40 +12,40 @@ makedepends=('cmake' 'git')
depends=('hicolor-icon-theme' 'qt6-base' 'qt6-declarative')
provides=('notes')
conflicts=('notes')
-source=('git+https://github.com/nuttyartist/notes.git'
- 'git+https://github.com/b00f/qautostart.git'
- 'git+https://github.com/pbek/qmarkdowntextedit.git'
- 'git+https://github.com/alex-spataru/QSimpleUpdater.git')
+source=("${pkgname}::git+https://github.com/nuttyartist/notes"
+ 'git+https://github.com/b00f/qautostart.git'
+ 'git+https://github.com/pbek/qmarkdowntextedit.git'
+ 'git+https://github.com/alex-spataru/QSimpleUpdater.git')
sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
- cd "${_pkgname}"
- git describe --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${pkgname}"
+ git describe --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${_pkgname}"
- git submodule init
- git submodule set-url 3rdParty/qautostart "${srcdir}/qautostart"
- git submodule set-url 3rdParty/qmarkdowntextedit "${srcdir}/qmarkdowntextedit"
- git submodule set-url 3rdParty/QSimpleUpdater "${srcdir}/QSimpleUpdater"
- git -c protocol.file.allow=always submodule update
+ cd "${pkgname}"
+ git submodule init
+ git submodule set-url 3rdParty/qautostart "${srcdir}/qautostart"
+ git submodule set-url 3rdParty/qmarkdowntextedit "${srcdir}/qmarkdowntextedit"
+ git submodule set-url 3rdParty/QSimpleUpdater "${srcdir}/QSimpleUpdater"
+ git -c protocol.file.allow=always submodule update
}
build() {
- cd "${_pkgname}"
- cmake -B build \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DUSE_QT_VERSION=6 \
- -DUPDATE_CHECKER=OFF
- cmake --build build
+ cd "${pkgname}"
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_QT_VERSION=6 \
+ -DUPDATE_CHECKER=OFF
+ cmake --build build
}
package() {
- cd "${_pkgname}"
- DESTDIR="${pkgdir}" cmake --install build
+ cd "${pkgname}"
+ DESTDIR="${pkgdir}" cmake --install build
}