summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-07 16:37:40 +0800
committerzxp198210052024-02-07 16:37:40 +0800
commitada305df93679fd29351327325cb874d4bb687da (patch)
tree6242395b07d49cef3c14e23d4f39b7fbcf4f3fdb
parent67b59f3359f4b1d74b493fcbf9d1e47efa8c8dd0 (diff)
downloadaur-ada305df93679fd29351327325cb874d4bb687da.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--notes-nc.sh9
3 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e69b158a55c6..8bc097304981 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = notes-nc-bin
pkgdesc = Cross-platform Notes desktop application for markdown notes
pkgver = 0.8.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/mscharley/notes-nc
arch = x86_64
license = MIT
@@ -17,6 +17,6 @@ pkgbase = notes-nc-bin
source = notes-nc.sh
sha256sums = e0408b98f96518be982163e9268e9b715b8e76abb09b1d7fd36df08467586c59
sha256sums = 3dcc1e196d70d5503a020194e91d5d663f428c349622d1f0eb545ec2f354264b
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
pkgname = notes-nc-bin
diff --git a/PKGBUILD b/PKGBUILD
index bf3e6a059d81..7b3091683e21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=notes-nc-bin
_pkgname=Notes
pkgver=0.8.0
_electronversion=26
-pkgrel=3
+pkgrel=4
pkgdesc="Cross-platform Notes desktop application for markdown notes"
arch=('x86_64')
url="https://github.com/mscharley/notes-nc"
@@ -26,11 +26,11 @@ source=(
)
sha256sums=('e0408b98f96518be982163e9268e9b715b8e76abb09b1d7fd36df08467586c59'
'3dcc1e196d70d5503a020194e91d5d663f428c349622d1f0eb545ec2f354264b'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/notes-nc.sh b/notes-nc.sh
index aacd8f895847..f9ced1432cfc 100644
--- a/notes-nc.sh
+++ b/notes-nc.sh
@@ -1,15 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file