summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbaltic2017-07-18 14:45:59 +0300
committerbaltic2017-07-18 14:45:59 +0300
commit350b318ed7fffcd08c4c2e87e21814f540fc21bc (patch)
treebd21c63ebc8cefed7989647347258ab4a197c685
downloadaur-350b318ed7fffcd08c4c2e87e21814f540fc21bc.tar.gz
Let's begin
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..014a26ae1b6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = notes-tree
+ pkgdesc = Note taking (knowledge base) app with tree like notes structure
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://bitbucket.org/baltic/notestree/src
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ license = ZLIB
+ makedepends = boost
+ depends = qt5-svg
+ depends = qt5-webkit
+ depends = boost-libs
+ depends = gtk-update-icon-cache
+ depends = desktop-file-utils
+ source = https://bitbucket.org/baltic/notestree/downloads/notes-tree-1.0.tar.xz
+ sha256sums = ad81cd9e064e9640783a260e4f19f30e971a7fd5f22ed06272c7c7b04d1ef711
+
+pkgname = notes-tree
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d71264029d5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: baltic <1000Hz.radiowave at google mail>
+pkgname=notes-tree
+pkgver=1.0
+pkgrel=1
+epoch=
+pkgdesc="Note taking (knowledge base) app with tree like notes structure"
+arch=('i686' 'x86_64' 'aarch64')
+url="https://bitbucket.org/baltic/notestree/src"
+license=('ZLIB')
+depends=(
+ 'qt5-svg'
+ 'qt5-webkit'
+ 'boost-libs'
+ 'gtk-update-icon-cache'
+ 'desktop-file-utils')
+makedepends=(
+ 'boost')
+source=("https://bitbucket.org/baltic/notestree/downloads/$pkgname-$pkgver.tar.xz")
+sha256sums=('ad81cd9e064e9640783a260e4f19f30e971a7fd5f22ed06272c7c7b04d1ef711')
+validpgpkeys=()
+
+build() {
+ cd "$srcdir"
+ qmake-qt5
+ make -j$(nproc)
+}
+
+package() {
+ cd "$srcdir"
+ make INSTALL_ROOT=$pkgdir install
+}