summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip Ponjavic2017-11-11 02:25:56 +0100
committerJosip Ponjavic2017-11-11 02:25:56 +0100
commit2456c7ab54750d4c091b147f2149f430f7fe8794 (patch)
tree0f827e3e85be8eab3c7dce1f495c8ac6e8b26b82
downloadaur-2456c7ab54750d4c091b147f2149f430f7fe8794.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c34999409cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = notes-up-git
+ pkgdesc = Notes Up is a notes manager written for elementary OS
+ pkgver = 1.4.7.r26.gd6bf17b
+ pkgrel = 1
+ url = https://github.com/Philip-Scott/Notes-up
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ makedepends = vala
+ depends = gtksourceview3
+ depends = gtkspell3
+ depends = libgranite.so
+ depends = webkit2gtk
+ provides = notes-up
+ conflicts = notes-up
+ source = git+https://github.com/Philip-Scott/Notes-up.git
+ sha256sums = SKIP
+
+pkgname = notes-up-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d9d1ea09f94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
+# Contributor:
+
+pkgname=notes-up-git
+pkgver=1.4.7.r26.gd6bf17b
+pkgrel=1
+pkgdesc="Notes Up is a notes manager written for elementary OS"
+arch=('i686' 'x86_64')
+url="https://github.com/Philip-Scott/Notes-up"
+license=('GPL2')
+depends=('gtksourceview3' 'gtkspell3' 'libgranite.so' 'webkit2gtk')
+makedepends=('cmake' 'git' 'vala')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd Notes-up
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../Notes-up -Dnoele=1 -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}