summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFernando Cladera2016-09-29 19:07:52 -0300
committerFernando Cladera2016-09-29 19:07:52 -0300
commit25a263293261894d3b0de9ede0e2433f32db7229 (patch)
tree183df92f8ad0a7cefd3b5f8fa024e98044bc774c
parentbfaaa9298ee7e81d9df0ef5aa6977ee8b3f71c94 (diff)
downloadaur-25a263293261894d3b0de9ede0e2433f32db7229.tar.gz
Version 0.1.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9eb2f96d5940..cd53b82e119c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = noteshrink
pkgdesc = Convert scans of handwritten notes to beautiful, compact PDFs
- pkgver = 0.1.0
+ pkgver = 0.1.1
pkgrel = 1
url = https://mzucker.github.io/2016/09/20/noteshrink.html
arch = any
license = MIT
- depends = python2
- depends = python2-numpy
- depends = python2-scipy
- depends = python2-pillow
- source = https://pypi.python.org/packages/4a/2f/9f3e67bf054f88d79a3af567d97106e33ec0cf12cf755b1810c6ad7dcd3b/noteshrink-0.1.0.tar.gz
- md5sums = 713e0ed307fbc19a9413d71aa6ba95aa
+ depends = python-numpy>=1.10
+ depends = python-scipy
+ depends = python-pillow
+ depends = imagemagick
+ conflicts = noteshrink-git
+ source = https://pypi.python.org/packages/13/a3/95c92cd5c250d3eb21ced23d1a7d1dabb1546e565fa4cdeaa72586ef871e/noteshrink-0.1.1.tar.gz
+ md5sums = 15dbdce38252e2209161cf415c3842f8
pkgname = noteshrink
diff --git a/PKGBUILD b/PKGBUILD
index 78292ddf4f3a..5515cf53d86e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Fernando Cladera <fcladera [at] fcladera [dot] com>
pkgname=noteshrink
-pkgver=0.1.0
+pkgver=0.1.1
pkgrel=1
pkgdesc="Convert scans of handwritten notes to beautiful, compact PDFs"
url='https://mzucker.github.io/2016/09/20/noteshrink.html'
arch=('any')
license=('MIT')
-depends=('python2' 'python2-numpy' 'python2-scipy' 'python2-pillow')
-source=('https://pypi.python.org/packages/4a/2f/9f3e67bf054f88d79a3af567d97106e33ec0cf12cf755b1810c6ad7dcd3b/noteshrink-0.1.0.tar.gz')
-md5sums=('713e0ed307fbc19a9413d71aa6ba95aa')
+depends=('python-numpy>=1.10' 'python-scipy' 'python-pillow' 'imagemagick')
+conflicts=('noteshrink-git')
+source=('https://pypi.python.org/packages/13/a3/95c92cd5c250d3eb21ced23d1a7d1dabb1546e565fa4cdeaa72586ef871e/'$pkgname'-'$pkgver'.tar.gz')
+md5sums=('15dbdce38252e2209161cf415c3842f8')
build() {
cd "$srcdir/$pkgname-$pkgver"
- sed -i '1 s/python/python2/g' noteshrink.py
- python2 setup.py build
+ python setup.py build
}
package() {
cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py install --root="$pkgdir" --optimize=1
+ python setup.py install --root="$pkgdir" --optimize=1
}