summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFernando Cladera2016-09-23 15:43:20 -0300
committerFernando Cladera2016-09-23 15:43:20 -0300
commitbfaaa9298ee7e81d9df0ef5aa6977ee8b3f71c94 (patch)
treecbbe78e96e4f49d9c6adde23d12273462517ee0a
parenta0160f623f86debbb8f16f84b9dafc151c6587da (diff)
downloadaur-bfaaa9298ee7e81d9df0ef5aa6977ee8b3f71c94.tar.gz
Stable version using Pypi
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 10 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b63cf8676ff5..9eb2f96d5940 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = noteshrink
pkgdesc = Convert scans of handwritten notes to beautiful, compact PDFs
- pkgver = r27.ab3178d
+ pkgver = 0.1.0
pkgrel = 1
url = https://mzucker.github.io/2016/09/20/noteshrink.html
arch = any
@@ -9,8 +9,8 @@ pkgbase = noteshrink
depends = python2-numpy
depends = python2-scipy
depends = python2-pillow
- source = git+http://github.com/mzucker/noteshrink.git
- md5sums = SKIP
+ source = https://pypi.python.org/packages/4a/2f/9f3e67bf054f88d79a3af567d97106e33ec0cf12cf755b1810c6ad7dcd3b/noteshrink-0.1.0.tar.gz
+ md5sums = 713e0ed307fbc19a9413d71aa6ba95aa
pkgname = noteshrink
diff --git a/PKGBUILD b/PKGBUILD
index 9902086336aa..78292ddf4f3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,24 @@
# Maintainer: Fernando Cladera <fcladera [at] fcladera [dot] com>
pkgname=noteshrink
-pkgver=r27.ab3178d
+pkgver=0.1.0
pkgrel=1
pkgdesc="Convert scans of handwritten notes to beautiful, compact PDFs"
url='https://mzucker.github.io/2016/09/20/noteshrink.html'
arch=('any')
license=('MIT')
depends=('python2' 'python2-numpy' 'python2-scipy' 'python2-pillow')
-source=('git+http://github.com/mzucker/noteshrink.git')
-md5sums=('SKIP')
+source=('https://pypi.python.org/packages/4a/2f/9f3e67bf054f88d79a3af567d97106e33ec0cf12cf755b1810c6ad7dcd3b/noteshrink-0.1.0.tar.gz')
+md5sums=('713e0ed307fbc19a9413d71aa6ba95aa')
-pkgver() {
- cd "$srcdir/$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
sed -i '1 s/python/python2/g' noteshrink.py
+ python2 setup.py build
}
-
-
package() {
- cd "$srcdir/$pkgname"
- install -Dm755 noteshrink.py $pkgdir/usr/bin/noteshrink
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
}