summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFernando Cladera2016-09-23 13:46:33 -0300
committerFernando Cladera2016-09-23 13:46:33 -0300
commita0160f623f86debbb8f16f84b9dafc151c6587da (patch)
treeefa6136c48967d3d6152b08168259553a944ce84
downloadaur-a0160f623f86debbb8f16f84b9dafc151c6587da.tar.gz
First version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b63cf8676ff5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = noteshrink
+ pkgdesc = Convert scans of handwritten notes to beautiful, compact PDFs
+ pkgver = r27.ab3178d
+ pkgrel = 1
+ url = https://mzucker.github.io/2016/09/20/noteshrink.html
+ arch = any
+ license = MIT
+ depends = python2
+ depends = python2-numpy
+ depends = python2-scipy
+ depends = python2-pillow
+ source = git+http://github.com/mzucker/noteshrink.git
+ md5sums = SKIP
+
+pkgname = noteshrink
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9902086336aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Fernando Cladera <fcladera [at] fcladera [dot] com>
+
+pkgname=noteshrink
+pkgver=r27.ab3178d
+pkgrel=1
+pkgdesc="Convert scans of handwritten notes to beautiful, compact PDFs"
+url='https://mzucker.github.io/2016/09/20/noteshrink.html'
+arch=('any')
+license=('MIT')
+depends=('python2' 'python2-numpy' 'python2-scipy' 'python2-pillow')
+source=('git+http://github.com/mzucker/noteshrink.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ sed -i '1 s/python/python2/g' noteshrink.py
+}
+
+
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 noteshrink.py $pkgdir/usr/bin/noteshrink
+}