summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2023-06-10 22:11:19 +0200
committerbegin-theadventure2023-06-10 22:11:19 +0200
commit1f3e292fac2c26ca54078406a3b6823afd6b6bfa (patch)
treeecde3a05527faf2f949f5cd45aad5cea7dbdba21
parentf479ab4ed64eecc4ae56d3262e9499c90bed16b8 (diff)
downloadaur-1f3e292fac2c26ca54078406a3b6823afd6b6bfa.tar.gz
2.5.2 and use git tag in source instead of git checkout
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b56da0aae6ef..aecc2b018f83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = notesnook
pkgdesc = A fully open source & end-to-end encrypted note taking alternative to Evernote
- pkgver = 2.5.0
+ pkgver = 2.5.2
pkgrel = 1
url = https://github.com/streetwriters/notesnook
arch = any
@@ -16,7 +16,7 @@ pkgbase = notesnook
provides = notesnook
conflicts = notesnook
options = !strip
- source = notesnook::git+https://github.com/streetwriters/notesnook.git
+ source = git+https://github.com/streetwriters/notesnook.git#tag=v2.5.2
source = notesnook.desktop
sha256sums = SKIP
sha256sums = f0e084aa6dae51e4f18962f5ca2b83c4150dc26dfad69301f0e8d2d0d0d876b5
diff --git a/PKGBUILD b/PKGBUILD
index 44fed5fd5f32..2efd087f3542 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Christian Finnberg <christian@finnberg.net>
pkgname=notesnook
-pkgver=2.5.0
+pkgver=2.5.2
pkgrel=1
_electronversion=21
pkgdesc="A fully open source & end-to-end encrypted note taking alternative to Evernote"
@@ -18,7 +18,7 @@ provides=(${pkgname})
conflicts=(${pkgname})
depends=("electron$_electronversion" 'libappindicator-gtk3' 'libnotify' 'libxss' 'libxtst')
makedepends=('nvm' 'git' 'yarn')
-source=("notesnook::git+$url.git"
+source=("git+$url.git#tag=v$pkgver"
"${pkgname}.desktop")
sha256sums=('SKIP'
'f0e084aa6dae51e4f18962f5ca2b83c4150dc26dfad69301f0e8d2d0d0d876b5')
@@ -29,7 +29,6 @@ prepare() {
build() {
cd notesnook
- git checkout tags/v${pkgver}
source /usr/share/nvm/init-nvm.sh && nvm use lts/gallium --silent
electronDist=/usr/lib/electron$_electronversion
electronVer=$(electron$_electronversion --version | tail -c +2)