summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-24 18:54:03 +0800
committerzxp198210052023-08-24 18:54:03 +0800
commit6eab4bf7ea0b43ec8a265ebcc9eeeabcb79ffedd (patch)
treefb4e1df042bebe4bb119e20d367a43bdc32c4c08
parent9f8f324ac0ca71f4ab3e597c67eff16e1956c5f9 (diff)
downloadaur-6eab4bf7ea0b43ec8a265ebcc9eeeabcb79ffedd.tar.gz
update to 2.6.1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD92
-rw-r--r--notesnook.desktop8
3 files changed, 50 insertions, 70 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 725d01a5f91c..c2555e9fc7ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,27 @@
pkgbase = notesnook
pkgdesc = A fully open source & end-to-end encrypted note taking alternative to Evernote
- pkgver = 2.5.5
- pkgrel = 2
- url = https://github.com/streetwriters/notesnook
+ pkgver = 2.6.1
+ pkgrel = 1
+ url = https://notesnook.com/
arch = any
license = GPL3
- makedepends = nvm
+ makedepends = nodejs>=18
makedepends = git
makedepends = yarn
- depends = electron21
depends = libappindicator-gtk3
depends = libnotify
depends = libsodium
depends = libxss
depends = libxtst
+ depends = fuse2
+ depends = alsa-lib
+ depends = nspr
+ depends = nss
provides = notesnook
conflicts = notesnook
- options = !strip
- source = git+https://github.com/streetwriters/notesnook.git#tag=v2.5.5
+ source = notesnook-2.6.1.tar.gz::https://github.com/streetwriters/notesnook/archive/refs/tags/v2.6.1.tar.gz
source = notesnook.desktop
- sha256sums = SKIP
- sha256sums = f0e084aa6dae51e4f18962f5ca2b83c4150dc26dfad69301f0e8d2d0d0d876b5
+ sha256sums = 81905d22d8d67417b2852070541802aafc4c588d213d8eca8fcb9a11b72cdb42
+ sha256sums = 0b8a124a5236be2ddb1797606b148b8ca144162b7f2aa628c252e2f35b2f8aea
pkgname = notesnook
diff --git a/PKGBUILD b/PKGBUILD
index 917d9ad140c0..bc3b646558a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,67 +4,45 @@
# Contributor: candroid_man <candroid_man@protonmail.com>
# Contributor: Ada <adadonderr@gmail.com>
# Contributor: Christian Finnberg <christian@finnberg.net>
-
pkgname=notesnook
-pkgver=2.5.5
-pkgrel=2
-_electronversion=21
+pkgver=2.6.1
+pkgrel=1
pkgdesc="A fully open source & end-to-end encrypted note taking alternative to Evernote"
arch=('any')
-url="https://github.com/streetwriters/notesnook"
+url="https://notesnook.com/"
+_githuburl="https://github.com/streetwriters/notesnook"
license=('GPL3')
-options=(!strip)
-provides=(${pkgname})
-conflicts=(${pkgname})
-depends=("electron$_electronversion" 'libappindicator-gtk3' 'libnotify' 'libsodium' 'libxss' 'libxtst')
-makedepends=('nvm' 'git' 'yarn')
-source=("git+$url.git#tag=v$pkgver"
- "${pkgname}.desktop")
-sha256sums=('SKIP'
- 'f0e084aa6dae51e4f18962f5ca2b83c4150dc26dfad69301f0e8d2d0d0d876b5')
-
-prepare() {
- source /usr/share/nvm/init-nvm.sh && nvm install lts/gallium
-}
-
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+depends=('libappindicator-gtk3' 'libnotify' 'libsodium' 'libxss' 'libxtst' 'fuse2' 'alsa-lib' 'nspr' 'nss')
+makedepends=('nodejs>=18' 'git' 'yarn')
+source=("${pkgname}-${pkgver}.tar.gz::${_githuburl}/archive/refs/tags/v${pkgver}.tar.gz"
+ "${pkgname}.desktop")
+sha256sums=('81905d22d8d67417b2852070541802aafc4c588d213d8eca8fcb9a11b72cdb42'
+ '0b8a124a5236be2ddb1797606b148b8ca144162b7f2aa628c252e2f35b2f8aea')
build() {
- cd notesnook
- source /usr/share/nvm/init-nvm.sh && nvm use lts/gallium --silent
- electronDist=/usr/lib/electron$_electronversion
- electronVer=$(electron$_electronversion --version | tail -c +2)
- export npm_config_build_from_source=true
- export npm_config_cache="$srcdir/npm_cache"
- export ELECTRON_SKIP_BINARY_DOWNLOAD=1
-
- # Build @notesnook/web
- npm install
- npm run build:web
-
- # Prepare files to pack with electron
- cd apps/desktop
- npm install
- rm -rf ./build && cp -r ../build ./
- npm run build
-
- # Build with electron
- npx electron-builder --linux --x64 --dir -c.electronDist=$electronDist -c.electronVersion=$electronVer --publish=never
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ # Build @notesnook/web
+ npm install
+ npm run build:web
+ # Prepare files to pack with electron
+ cd apps/desktop
+ npm install
+ rm -rf ./build
+ cp -r ../web/build ./
+ sed '155,161d' -i package.json
+ npm run build
+ # Build with electron
+ npx electron-builder --linux --publish=never
}
-
package() {
- cd notesnook/apps/desktop
- install -d "${pkgdir}"/{opt/${pkgname},usr/bin}
-
- # Copy electron build
- cp -va dist/linux-unpacked/. -t "${pkgdir}/opt/${pkgname}"
-
- # Icons
- for i in 16 24 32 48 64 128 256 512 1024; do
- install -vDm644 assets/icons/${i}x${i}.png "${pkgdir}"/usr/share/icons/hicolor/${i}x${i}/apps/${pkgname}.png
- done
-
- # Symlink
- ln -s /opt/${pkgname}/${pkgname} "${pkgdir}/usr/bin"
-
- # Desktop file
- install -vDm644 "${srcdir}"/${pkgname}.desktop -t "${pkgdir}"/usr/share/applications
-}
+ install Dm755 -d "${pkgdir}/"{opt/${pkgname},usr/bin}
+ local X64=linux-unpacked ARM64=linux-arm64-unpacked
+ cp -r "${srcdir}/${pkgname}-${pkgver}/apps/desktop/output/${X64}/"* "${pkgdir}/opt/${pkgname}"
+ ln -sf "/opt/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ for _icons in 16x16 24x24 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024;do
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/apps/desktop/output/${X64}/resources/assets/icons/${_icons}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname}.png"
+ done
+ install -Dm644 "${srcdir}/${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+} \ No newline at end of file
diff --git a/notesnook.desktop b/notesnook.desktop
index 9076c15c6c93..d7ce45a8a559 100644
--- a/notesnook.desktop
+++ b/notesnook.desktop
@@ -1,6 +1,6 @@
[Desktop Entry]
Name=Notesnook
-Exec=/opt/notesnook/notesnook %U
+Exec=notesnook %U
Terminal=false
Type=Application
Icon=notesnook
@@ -12,12 +12,12 @@ Actions=new-note;new-notebook;new-reminder;
[Desktop Action new-note]
Name=New note
-Exec=/opt/notesnook/notesnook %U new note
+Exec=notesnook %U new note
[Desktop Action new-notebook]
Name=New notebook
-Exec=/opt/notesnook/notesnook %U new notebook
+Exec=notesnook %U new notebook
[Desktop Action new-reminder]
Name=New reminder
-Exec=/opt/notesnook/notesnook %U new reminder
+Exec=notesnook %U new reminder