summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-23 12:37:19 +0800
committerzxp198210052023-11-23 12:37:19 +0800
commit79802a2e5c3d07c21d44dc10c75fd4c358ea1c37 (patch)
treef9f51293065884cdd70f28990745ac587e47a861
parentd88ed42a6edd85b81ca74b401870c8845294291a (diff)
downloadaur-79802a2e5c3d07c21d44dc10c75fd4c358ea1c37.tar.gz
update to 2.6.11
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--notesnook.sh0
3 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a464c725f1ba..44d449eb1b92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = notesnook
pkgdesc = A fully open source & end-to-end encrypted note taking alternative to Evernote
- pkgver = 2.6.10
+ pkgver = 2.6.11
pkgrel = 1
url = https://notesnook.com/
arch = x86_64
@@ -17,9 +17,9 @@ pkgbase = notesnook
depends = alsa-lib
depends = nspr
depends = nss
- provides = notesnook=2.6.10
+ provides = notesnook=2.6.11
conflicts = notesnook
- source = notesnook-2.6.10::git+https://github.com/streetwriters/notesnook.git#tag=v2.6.10
+ source = notesnook-2.6.11::git+https://github.com/streetwriters/notesnook.git#tag=v2.6.11
source = notesnook.desktop
sha256sums = SKIP
sha256sums = 102a538ee9432310d854842a578cd3371df0431b4db617479de66aa45b5f2440
diff --git a/PKGBUILD b/PKGBUILD
index a1e36a160989..13d01b800d2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Ada <adadonderr@gmail.com>
# Contributor: Christian Finnberg <christian@finnberg.net>
pkgname=notesnook
-pkgver=2.6.10
+pkgver=2.6.11
pkgrel=1
pkgdesc="A fully open source & end-to-end encrypted note taking alternative to Evernote"
arch=('x86_64')
@@ -51,11 +51,12 @@ build() {
-e "3i\ \"author\": \"Streetwriters (Private) Limited,support@streetwriters.co,https://streetwriters.co\"," \
-e "55i\ \"electron\": \"25.9.3\"," \
-i package.json
- npm install --ignore-scripts --prefer-offline --no-audit --cache "${srcdir}/npm-cache"
- npm run bootstrap -- --scope=desktop
+ npm install --ignore-scripts --prefer-offline --no-audit --cache "${srcdir}/npm-cache"
+ npm run bootstrap -- --scope=web
npx nx build:desktop @notesnook/web
+ npm run bootstrap -- --scope=desktop
npx nx run release --project @notesnook/desktop
- npx electron-builder --linux tar.xz -p never
+ npx electron-builder --linux AppImage -p never
}
package() {
install -Dm755 -d "${pkgdir}/"{opt/${pkgname},usr/bin}
diff --git a/notesnook.sh b/notesnook.sh
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/notesnook.sh