summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-04-29 16:40:10 +0800
committerzxp198210052024-04-29 16:40:10 +0800
commit321cb6ce332b890587c9b8f5eb342773b2e07bdf (patch)
tree741c1c1c7f5d13c37fa8814e7457b05f6c9fd13b
parent76fbd8b94869ca8b359ad178cb44afdd898c9c2d (diff)
downloadaur-321cb6ce332b890587c9b8f5eb342773b2e07bdf.tar.gz
update to 3.0.0.r1.gfe91ef79a
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
-rw-r--r--notesnook.sh9
3 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ebb9c12fc25..e02483b7c5d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = notesnook-git
pkgdesc = A fully open source & end-to-end encrypted note taking alternative to Evernote
- pkgver = 3.0.13.beta.r0.gc54759e76
+ pkgver = 3.0.0.r1.gfe91ef79a
pkgrel = 1
url = https://notesnook.com/
arch = aarch64
@@ -13,14 +13,15 @@ pkgbase = notesnook-git
makedepends = base-devel
makedepends = gcc
makedepends = curl
- depends = electron25-bin
- provides = notesnook=3.0.13.beta
+ depends = electron29
+ depends = nodejs
+ provides = notesnook=3.0.0
conflicts = notesnook
source = notesnook.git::git+https://github.com/streetwriters/notesnook.git
source = notesnook.desktop
source = notesnook.sh
sha256sums = SKIP
sha256sums = efc8a6cea79ed0203dcbadf17632b5341952a49704f99e3ea0ddc573b06748f4
- sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
+ sha256sums = 61d56055897e9d71d68e185ac2de7c4cb2fbca16eb3fb0091703612c113441f3
pkgname = notesnook-git
diff --git a/PKGBUILD b/PKGBUILD
index 679bd9c79634..676c094f9b79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributer: Ada <adadonderr@gmail.com>
# Contributor: Christian Finnberg <christian@finnberg.net>
pkgname=notesnook-git
-pkgver=3.0.13.beta.r0.gc54759e76
-_electronversion=25
-_nodeversion=16
+pkgver=3.0.0.r1.gfe91ef79a
+_electronversion=29
+_nodeversion=20
pkgrel=1
pkgdesc="A fully open source & end-to-end encrypted note taking alternative to Evernote"
arch=(
@@ -18,7 +18,8 @@ license=('GPL-3.0-or-later')
provides=("${pkgname%-git}=${pkgver%.r*}")
conflicts=("${pkgname%-git}")
depends=(
- "electron${_electronversion}-bin"
+ "electron${_electronversion}"
+ 'nodejs'
)
makedepends=(
'nvm'
@@ -36,7 +37,7 @@ source=(
)
sha256sums=('SKIP'
'efc8a6cea79ed0203dcbadf17632b5341952a49704f99e3ea0ddc573b06748f4'
- 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+ '61d56055897e9d71d68e185ac2de7c4cb2fbca16eb3fb0091703612c113441f3')
pkgver() {
cd "${srcdir}/${pkgname//-/.}"
git describe --long --tags | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g;s/.android//g'
@@ -51,7 +52,7 @@ build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname}|g" \
-e "s|@runname@|app|g" \
- -e "s|@options@||g" \
+ -e "s|@options@|env ELECTRON_OZONE_PLATFORM_HINT=auto|g" \
-i "${srcdir}/${pkgname%-git}.sh"
_ensure_local_nvm
export npm_config_build_from_source=true
diff --git a/notesnook.sh b/notesnook.sh
index 7ddcaab8d734..842c77e19b1d 100644
--- a/notesnook.sh
+++ b/notesnook.sh
@@ -8,9 +8,14 @@ export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}
export ELECTRON_IS_DEV=0
export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
+export XDG_CONFIG_HOME="${XDG_CONFIG_HOME:-$HOME/.config}"
+_FLAGS_FILE="${XDG_CONFIG_HOME}/@appname@-flags.conf"
+if [ -r "${_FLAGS_FILE}" ]; then
+ _USER_FLAGS="$(cat "${_FLAGS_FILE}")"
+fi
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "${_USER_FLAGS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "${_USER_FLAGS}" "$@" || exit $?
fi \ No newline at end of file