summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Vogt2015-06-17 10:38:12 +0200
committerDavid Vogt2015-06-17 10:38:12 +0200
commitd829ab87929d29121901e9a3e4a009b3af7dd5d9 (patch)
treef13f557cf0a1c06fd79e08baa4c0e9f95732ba09
downloadaur-d829ab87929d29121901e9a3e4a009b3af7dd5d9.tar.gz
initial, moved over from http://github.com/winged/aur-packages
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e54bd9f8f4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = notevim-git
+ pkgdesc = A script to help you manage your notes and access them quickly
+ pkgver = 0.r13.18f2688
+ pkgrel = 3
+ url = https://github.com/winged/notevim
+ arch = x86_64
+ arch = i686
+ license = BSD
+ depends = wmctrl
+ optdepends = python2-neovim: If you want to use it with Neovim
+ provides = notevim
+ provides = notevim-git
+ source = notevim-git::git://github.com/winged/notevim.git
+ source = LICENSE::https://raw.githubusercontent.com/winged/notevim/master/LICENSE
+ sha256sums = SKIP
+ sha256sums = 2eb36a7daa0b8aebd44467eefd37ef289c99cfdd4c7189d5c436a7bef8ce1c51
+
+pkgname = notevim-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c106ac7ba9d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: David Vogt <dave at winged dot ch>
+# This PKGBUILD is maintained at https://github.com/winged/aur-packages
+
+pkgname=notevim-git
+pkgver=0.r13.18f2688
+pkgrel=3
+pkgdesc="A script to help you manage your notes and access them quickly"
+arch=('x86_64' 'i686')
+license=('BSD')
+url=('https://github.com/winged/notevim')
+depends=('wmctrl')
+provides=('notevim' 'notevim-git')
+conflicts=()
+#makedepends=('python2-setuptools')
+optdepends=('python2-neovim: If you want to use it with Neovim')
+
+source=("$pkgname::git://github.com/winged/notevim.git"
+ "LICENSE::https://raw.githubusercontent.com/winged/notevim/master/LICENSE")
+sha256sums=('SKIP' '2eb36a7daa0b8aebd44467eefd37ef289c99cfdd4c7189d5c436a7bef8ce1c51')
+pkgver() {
+ cd "${pkgname}"
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ if [ ! -d "$pkgdir/usr/bin" ]; then
+ mkdir -p "$pkgdir/usr/bin"
+ fi
+ install notevim "$pkgdir/usr/bin"
+}
+
+# vim:set ts=2 sw=2 et: