summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSibren Vasse2020-06-03 12:38:50 +0200
committerSibren Vasse2020-06-03 12:38:50 +0200
commiteea8110192db553b38f080b8999163a6d7dfd2dc (patch)
treec686687581a734b5f7e63a5f3684922f7f54882d
parentc820af7b3a13615b3972acfce48a0d79783f8188 (diff)
downloadaur-eea8110192db553b38f080b8999163a6d7dfd2dc.tar.gz
Go package guidelines
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8490cf0b1ca7..81bfe7275ebc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = noti
pkgdesc = Monitor a process and trigger a notification
pkgver = 3.4.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/variadico/noti
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 1f99e4ac0e0a..ee00d12e3751 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sibren Vasse <arch@sibrenvasse.nl>
pkgname=noti
pkgver=3.4.0
-pkgrel=2
+pkgrel=3
pkgdesc='Monitor a process and trigger a notification'
arch=('x86_64')
url='https://github.com/variadico/noti'
@@ -13,9 +13,11 @@ sha256sums=('8fcf494084ea6eacac2e55dfcaf978452e1af0139205cd23fce71bfb20dd17fe')
build() {
cd "$pkgname-$pkgver"
go build \
- -mod=vendor \
-trimpath \
- -ldflags "-extldflags $LDFLAGS" \
+ -buildmode=pie \
+ -mod=vendor \
+ -modcacherw \
+ -ldflags "-extldflags \"${LDFLAGS}\"" \
-o $pkgname \
github.com/variadico/noti/cmd/noti
}