summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Milon2016-10-31 17:52:20 +0200
committerDan Milon2016-10-31 17:52:20 +0200
commitbe4dde36401afdf94c417434cc5d6f855082ced8 (patch)
treedf842f839d1536d17ef5596625e4463a61b1bd83
downloadaur-be4dde36401afdf94c417434cc5d6f855082ced8.tar.gz
init commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d43c00d6d152
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = notification-thing-git
+ pkgdesc = Python-based implementation of Desktop Notifications Specification (notification-daemon)
+ pkgver = 20161031
+ pkgrel = 1
+ url = https://github.com/mk-fg/notification-thing
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = python2-dbus
+ depends = python2-gobject
+ optdepends = python2-yaml: to configure daemon via YAML file, not CLI (--conf option).
+ optdepends = python2-pyzmq: to broadcast/receive notification messages over zeromq pub/sub sockets.
+ optdepends = libcanberra: to play sounds (from XDG themes or files).
+ provides = notification-thing
+ source = notification-thing-git::git://github.com/mk-fg/notification-thing.git
+ md5sums = SKIP
+
+pkgname = notification-thing-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1357bc37646c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: <i@danmilon.me>
+pkgname=notification-thing-git
+pkgver=20161031
+pkgver() {
+ date +%Y%m%d
+}
+pkgrel=1
+epoch=
+pkgdesc="Python-based implementation of Desktop Notifications Specification (notification-daemon)"
+arch=(any)
+url="https://github.com/mk-fg/notification-thing"
+license=('unknown')
+groups=()
+depends=('python2-dbus' 'python2-gobject')
+makedepends=(git)
+checkdepends=()
+optdepends=(
+ 'python2-yaml: to configure daemon via YAML file, not CLI (--conf option).'
+ 'python2-pyzmq: to broadcast/receive notification messages over zeromq pub/sub sockets.'
+ 'libcanberra: to play sounds (from XDG themes or files).')
+provides=('notification-thing')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname::git://github.com/mk-fg/notification-thing.git")
+md5sums=('SKIP')
+noextract=()
+
+package() {
+ cd "$srcdir/$pkgname"
+ python2 setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: