summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2020-12-31 21:29:11 +0600
committerMubashshir2020-12-31 21:29:11 +0600
commit98141a0fa17798bffe8ae71152acb1be2f3d3f50 (patch)
tree20da98439eaf6eb90313171e95414b3f38b84065
parentcdbaa508b4d52ab311fa7f1734e7fe7d19147135 (diff)
downloadaur-98141a0fa17798bffe8ae71152acb1be2f3d3f50.tar.gz
pkgrel bump.
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD14
-rwxr-xr-xnotify-send.py2
4 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5373cd00281b..502b59d5924b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = notify-send-py
pkgdesc = A python script for sending desktop notifications from the shell
pkgver = 1.2.6
- pkgrel = 3
+ pkgrel = 5
url = https://github.com/phuhl/notify-send.py
arch = any
license = MIT
@@ -10,7 +10,9 @@ pkgbase = notify-send-py
depends = python-dbus
depends = python-gobject
source = notify-send-py-1.2.6.tar.gz::https://files.pythonhosted.org/packages/source/n/notify-send.py/notify-send.py-1.2.6.tar.gz
+ source = notify-send.py
sha256sums = 23f790d680221d93359bafb46b31e3af4830770cb4f0acb7c7321ab9af835b3c
+ sha256sums = e07e3213316a8eb3b4e3d952898075bb8a0db2edde7819770b7524d7bc592a91
pkgname = notify-send-py
diff --git a/.gitignore b/.gitignore
index e4f9ba3007cf..e927c3eadf08 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.SRCINFO
!PKGBUILD
!.gitignore
+!notify-send.py
diff --git a/PKGBUILD b/PKGBUILD
index 16b5d3bd4170..f9608d292b77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# pkg: pypi notify-send.py
pkgname=notify-send-py
pkgver=1.2.6
-pkgrel=3
+pkgrel=5
pkgdesc="A python script for sending desktop notifications from the shell"
arch=(any)
@@ -10,10 +10,11 @@ url=https://github.com/phuhl/notify-send.py
license=(MIT)
makedepends=(python-setuptools)
depends=( python-notify2 python-dbus python-gobject )
-_python="$(realpath /usr/bin/python|xargs basename)"
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname%-*}.${pkgname##*-}/${pkgname%-*}.${pkgname##*-}-$pkgver.tar.gz"
+ 'notify-send.py')
+sha256sums=('23f790d680221d93359bafb46b31e3af4830770cb4f0acb7c7321ab9af835b3c'
+ 'e07e3213316a8eb3b4e3d952898075bb8a0db2edde7819770b7524d7bc592a91')
-source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname%-*}.${pkgname##*-}/${pkgname%-*}.${pkgname##*-}-$pkgver.tar.gz")
-sha256sums=('23f790d680221d93359bafb46b31e3af4830770cb4f0acb7c7321ab9af835b3c')
build() {
cd "$srcdir/${pkgname%-*}.${pkgname##*-}-$pkgver"
python setup.py build
@@ -23,9 +24,6 @@ package()
{
cd "$srcdir/${pkgname%-*}.${pkgname##*-}-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- chmod +x \
- "$pkgdir/usr/lib/${_python}/site-packages/notify_send_py/notify_send_py.py"
- mkdir -p "$pkgdir/usr/bin"
- ln -s "../lib/${_python}/site-packages/notify_send_py/notify_send_py.py" "$pkgdir/usr/bin/notify-send.py"
+ install -Dm755 "$srcdir/notify-send.py" "$pkgdir/usr/bin/notify-send.py"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/notify-send.py b/notify-send.py
new file mode 100755
index 000000000000..62cc56dd4c72
--- /dev/null
+++ b/notify-send.py
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec python3 -m notify_send_py.notify_send_py "$@"