summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2020-10-04 22:59:08 +0600
committerMubashshir2020-10-04 22:59:08 +0600
commiteb1a24eaca3526d719f43277a970bb1a35ab8aec (patch)
treee8dc7e57c7e31dfdcdb54b0416921b1ce78d5c05
downloadaur-eb1a24eaca3526d719f43277a970bb1a35ab8aec.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0f4c61d86cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = notify-send-py
+ pkgdesc = A python script for sending desktop notifications from the shell
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://github.com/phuhl/notify-send.py
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-notify2
+ depends = python-dbus
+ depends = python-gobject
+ source = https://files.pythonhosted.org/packages/source/n/notify-send.py/notify-send.py-1.2.1.tar.gz
+ sha256sums = ae4573ca4a4071cd38dfc97b13a18a48124cdf9f23cd6b347bbd23284de31260
+
+pkgname = notify-send-py
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f9ba3007cf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.SRCINFO
+!PKGBUILD
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57cca5773ee4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Mubashshir <ahmubashshir@gmail.com>
+# pkg: pypi notify-send.py
+pkgname=notify-send-py
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="A python script for sending desktop notifications from the shell"
+
+arch=(any)
+url=https://github.com/phuhl/notify-send.py
+license=(MIT)
+makedepends=(python-setuptools)
+depends=( python-notify2 python-dbus python-gobject )
+
+source=(
+ "https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname%-*}.${pkgname##*-}/${pkgname%-*}.${pkgname##*-}-$pkgver.tar.gz"
+)
+sha256sums=('ae4573ca4a4071cd38dfc97b13a18a48124cdf9f23cd6b347bbd23284de31260')
+build() {
+ cd "$srcdir/${pkgname%-*}.${pkgname##*-}-$pkgver"
+ python setup.py build
+}
+
+package()
+{
+ cd "$srcdir/${pkgname%-*}.${pkgname##*-}-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}