summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTilman Blumenbach2013-09-28 20:08:14 +0200
committerTilman Blumenbach2013-09-28 20:08:14 +0200
commit6d0b564da5e77f2b8a7bbf5b5cf119eb8209ba5e (patch)
treefd67e5364f0ca5e35c75e4b9765c010e90fd8e83
downloadaur-6d0b564da5e77f2b8a7bbf5b5cf119eb8209ba5e.tar.gz
Added some of my AUR packages
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD56
-rw-r--r--notifyconf.desktop9
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d78390a45686
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = notifyconf
+ pkgdesc = GUI for configuring notify-osd-customizable
+ pkgver = 7
+ pkgrel = 4
+ url = https://launchpad.net/notifyconf
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = bzr
+ depends = notify-osd-customizable
+ depends = qt4
+ source = notifyconf.desktop
+ md5sums = 06b1fbde2b18edbe3e152797063a9306
+
+pkgname = notifyconf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84c77f6677fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# vim:set ts=2 sw=2 et:
+#
+# Maintainer: Tblue <tilman (AT) ax86 (DOT) net>
+# Contributor: dieghen89 <dieghen89@gmail.com>
+
+pkgname=notifyconf
+pkgver=7
+pkgrel=4
+pkgdesc="GUI for configuring notify-osd-customizable"
+url="https://launchpad.net/notifyconf"
+arch=('i686' 'x86_64')
+depends=('notify-osd-customizable' 'qt4')
+makedepends=('bzr')
+license=(GPL)
+source=('notifyconf.desktop')
+
+# Not using lp: handler because it makes bzr use pubkey auth which in turn
+# prompts me for my privkey password every time I build this package.
+_bzrtrunk='http://bazaar.launchpad.net/~amandeepgrewal/notifyconf/trunk'
+_bzrmod=notifyconf
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to Bazaar server...."
+
+ if [[ -d "$_bzrmod" ]]; then
+ cd "$_bzrmod" && bzr --no-plugins pull "$_bzrtrunk" -r "$pkgver"
+ msg "The local files are updated."
+ else
+ bzr --no-plugins branch "$_bzrtrunk" "$_bzrmod" -q -r "$pkgver"
+ fi
+
+ msg "Bazaar checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_bzrmod-build"
+ cp -r "$srcdir/$_bzrmod" "$srcdir/$_bzrmod-build"
+ cd "$srcdir/$_bzrmod-build"
+
+ #
+ # BUILD HERE
+ #
+ qmake-qt4
+ make
+}
+
+package() {
+ cd "$srcdir/$_bzrmod-build"
+
+ install -D -m 644 not.png "$pkgdir/usr/share/notifyosdconf/not.png"
+ install -D -m 644 default.def "$pkgdir/usr/share/notifyosdconf/default.def"
+ install -D -m 644 "$srcdir/notifyconf.desktop" "$pkgdir/usr/share/applications/notifyconf.desktop"
+ install -D -m 755 NotifyOSDConfiguration "$pkgdir/usr/bin/notifyconf"
+}
+
+md5sums=('06b1fbde2b18edbe3e152797063a9306')
diff --git a/notifyconf.desktop b/notifyconf.desktop
new file mode 100644
index 000000000000..8019d09c5500
--- /dev/null
+++ b/notifyconf.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=1.0
+Type=Application
+Name=NotifyOSD Configuration
+Comment=Tool to configure Ubuntu's notify-osd notification system
+Categories=GNOME;Applications;Utility;Qt
+Exec=notifyconf
+Icon=/usr/share/notifyosdconf/not.png