summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author--global2019-08-06 22:46:24 +0200
committer--global2019-08-06 22:46:24 +0200
commitf385642ee735a171be3d6cbc165bfd06b5fa0394 (patch)
treefc51f42074ee3ec69763d142e3268ff630300f1d
downloadaur-f385642ee735a171be3d6cbc165bfd06b5fa0394.tar.gz
Initial release of Notigo 2.0.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..617fb3e89180
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = notigo
+ pkgdesc = Send iOS/Android notifications using IFTTT's Webhook
+ pkgver = 2.0.2
+ pkgrel = 1
+ url = https://github.com/scotow/notigo
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ makedepends = git
+ source = notigo-2.0.2.tar.gz::https://github.com/scotow/notigo/archive/2.0.2.tar.gz
+ sha256sums = 59047afb6f30353da243ef97accf09cc0a0a251f5a19f6f0d0501ce2dd89897e
+
+pkgname = notigo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f190592b928
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Benjamin Lopez <contact@scotow.com>
+
+pkgname=notigo
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Send iOS/Android notifications using IFTTT's Webhook"
+arch=('x86_64')
+url="https://github.com/scotow/${pkgname}"
+license=('MIT')
+makedepends=('go' 'git')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/scotow/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('7b0ff0f61cced09a589aee8d9422c1b1560fa7468159cbf16513705da4e932f0')
+
+prepare(){
+ mkdir -p src/github.com/scotow
+ ln -rTsf "${pkgname}-${pkgver}" "src/github.com/scotow/${pkgname}"
+}
+
+build(){
+ export GOPATH="${srcdir}"
+ cd "src/github.com/scotow/${pkgname}"
+ go get -v ./...
+ go install \
+ -gcflags "all=-trimpath=${GOPATH}/src" \
+ -asmflags "all=-trimpath=${GOPATH}/src" \
+ -ldflags "-extldflags ${LDFLAGS}" \
+ ./cmd/...
+}
+
+package(){
+ install -Dm755 "bin/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+
+ cd "${pkgname}-${pkgver}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}