summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaime Martínez Rincón2021-05-28 21:09:42 +0200
committerJaime Martínez Rincón2021-05-28 21:09:42 +0200
commitc22af8254314142efcd79e83696b48792985ae2a (patch)
tree49e206d6257e5b01cf9d0261e983443e9e7d5a4e
parent536d1fbbfd88bc6c27ea9baa4bf4b0f0bfb10415 (diff)
downloadaur-c22af8254314142efcd79e83696b48792985ae2a.tar.gz
actually update to cld 2.7.0 correctly
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 506f989d93d0..e1a58a6f91c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = notion-app
pkgdesc = The all-in-one workspace for your notes and tasks
pkgver = 2.0.16
- pkgrel = 11
+ pkgrel = 12
epoch = 2
url = https://www.notion.so/desktop
arch = i686
@@ -13,6 +13,7 @@ pkgbase = notion-app
makedepends = nvm
makedepends = python2
makedepends = git
+ makedepends = jq
depends = re2
depends = gtk3
depends = xdg-utils
diff --git a/PKGBUILD b/PKGBUILD
index 782d42ea2ab0..d4bdfd439bc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=notion-app
pkgver=2.0.16
-pkgrel=11
+pkgrel=12
epoch=2
pkgdesc="The all-in-one workspace for your notes and tasks"
arch=('i686' 'x86_64')
url="https://www.notion.so/desktop"
license=('MIT')
depends=('re2' 'gtk3' 'xdg-utils')
-makedepends=('imagemagick' 'p7zip' 'npm' 'nvm' 'python2' 'git')
+makedepends=('imagemagick' 'p7zip' 'npm' 'nvm' 'python2' 'git' 'jq')
source=("Notion-"${pkgver}".exe::https://desktop-release.notion-static.com/Notion%20Setup%20${pkgver}.exe"
'notion-app.desktop')
md5sums=('9f72284086cda3977f7f569dff3974d5'
@@ -50,9 +50,11 @@ build() {
print_info "Recreating package node_modules..."
rm -r node_modules
+ PATCHED_PACKAGE_JSON=$(jq '.dependencies.cld="2.7.0"' package.json)
+ echo "${PATCHED_PACKAGE_JSON}" > package.json
+
npm install --cache "${srcdir}/npm-cache"
node_modules/.bin/patch-package
- npm install cld@2.7.0 --cache "${srcdir}/npm-cache"
print_info "Converting app icon..."
convert "icon.ico[0]" "icon.png" >/dev/null