summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaime Martínez Rincón2021-04-05 22:40:01 +0200
committerJaime Martínez Rincón2021-04-05 22:40:01 +0200
commitd05918ab8be947f66b179b3fa3252bd7fb290a5c (patch)
tree2ce54f1f0308fbe97146f129e880e8940d8560dd
parentad323ff5cb5e22e2bddee33473040fef0374c970 (diff)
downloadaur-d05918ab8be947f66b179b3fa3252bd7fb290a5c.tar.gz
Depend on electron11
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rwxr-xr-xnotion-app2
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29db753e95cc..8f6078ba817a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = notion-app
pkgdesc = The all-in-one workspace for your notes and tasks
pkgver = 2.0.11
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = https://www.notion.so/desktop
arch = i686
@@ -10,7 +10,7 @@ pkgbase = notion-app
makedepends = imagemagick
makedepends = p7zip
makedepends = asar
- depends = electron
+ depends = electron11
depends = re2
depends = gtk3
depends = xdg-utils
@@ -19,7 +19,7 @@ pkgbase = notion-app
source = notion-app
source = notion-app.desktop
md5sums = b3fb76f3cdc664e71e7438348c472a16
- md5sums = 6f4dfafeaaf5ef56c4eb5ef78792e063
+ md5sums = 89f5d6220dd0b8fb459ed59cff7dee3c
md5sums = dc75abd9b8f3f455a0b8fc0d8d8932b5
pkgname = notion-app
diff --git a/PKGBUILD b/PKGBUILD
index d59f6d1fa196..66992ba97463 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@
pkgname=notion-app
pkgver=2.0.11
-pkgrel=2
+pkgrel=3
epoch=1
pkgdesc="The all-in-one workspace for your notes and tasks"
arch=('i686' 'x86_64')
url="https://www.notion.so/desktop"
license=('MIT')
-depends=('electron' 're2' 'gtk3' 'xdg-utils')
+depends=('electron11' 're2' 'gtk3' 'xdg-utils')
makedepends=('imagemagick' 'p7zip' 'asar')
optdepends=('notion-enhancer: enhancements and fixes')
source=(
@@ -19,7 +19,7 @@ source=(
'notion-app'
'notion-app.desktop')
md5sums=('b3fb76f3cdc664e71e7438348c472a16'
- '6f4dfafeaaf5ef56c4eb5ef78792e063'
+ '89f5d6220dd0b8fb459ed59cff7dee3c'
'dc75abd9b8f3f455a0b8fc0d8d8932b5')
build() {
msg "Extracting app from Windows build..."
diff --git a/notion-app b/notion-app
index b86e4865742a..78c3de98bc60 100755
--- a/notion-app
+++ b/notion-app
@@ -8,5 +8,5 @@ if [[ ! -e "/opt/notion-app" ]]; then
fi
pushd "/opt/notion-app/" >/dev/null || exit 1
-electron app.asar $@
+electron11 app.asar $@
popd >/dev/null || exit 1