summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlegs Jeremejevs2020-03-19 17:54:25 +0000
committerOlegs Jeremejevs2020-03-19 18:02:48 +0000
commitcb9b92ffdbe2b22fb283af49c660aceab21d19aa (patch)
tree663a77295d5ad63c95304950547a71ca5894165e
downloadaur-cb9b92ffdbe2b22fb283af49c660aceab21d19aa.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD50
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..392c155fb6b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = notion-app-nativefier
+ pkgdesc = The all-in-one workspace for your notes, tasks, wikis, and databases
+ pkgver = 2020.03.18
+ pkgrel = 1
+ url = https://www.notion.so/
+ arch = any
+ license = custom
+ makedepends = curl
+ makedepends = gendesk
+ makedepends = nodejs-nativefier
+ depends = electron
+
+pkgname = notion-app-nativefier
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..742e720578b9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/*.tar
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d32d5e274a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Olegs Jeremejevs <olegs@jeremejevs.com>
+
+pkgname=notion-app-nativefier
+pkgver=2020.03.18
+pkgrel=1
+pkgdesc='The all-in-one workspace for your notes, tasks, wikis, and databases'
+arch=('any')
+url='https://www.notion.so/'
+license=('custom')
+depends=('electron')
+makedepends=(
+ 'curl'
+ 'gendesk'
+ 'nodejs-nativefier'
+)
+
+_name=Notion
+
+prepare() {
+ cat > "${pkgname}" <<EOF
+#!/usr/bin/env bash
+exec electron /usr/share/${pkgname} "\$@"
+EOF
+ gendesk \
+ --pkgname "${pkgname}" \
+ --pkgdesc "${pkgdesc}" \
+ --name "${_name}" \
+ -n \
+ -f
+ curl https://www.notion.so/images/logo-ios.png > "${pkgname}.png"
+}
+
+build() {
+ cd "${srcdir}"
+ nativefier \
+ --name "${_name}" \
+ --icon "${pkgname}.png" \
+ --maximize \
+ --single-instance \
+ --verbose \
+ www.notion.so
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/share"
+ cp -r "${_name}-linux-"*"/resources/app" "${pkgdir}/usr/share/${pkgname}"
+ install -D -m 755 -t "${pkgdir}/usr/bin/" "${pkgname}"
+ install -D -m 644 -t "${pkgdir}/usr/share/applications/" "${pkgname}.desktop"
+ install -D -m 644 -t "${pkgdir}/usr/share/pixmaps/" "${pkgname}.png"
+}