summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNek-122020-08-28 19:02:55 +0300
committerNek-122020-08-28 19:02:55 +0300
commite6962f4e812fa79223d6bd667ed849b8365f5e95 (patch)
tree31adbe0534a9d3ea40a8b2f2df0ca2c663824130
parentc7186ddce032d01f41947a0c6c1462543196a389 (diff)
downloadaur-e6962f4e812fa79223d6bd667ed849b8365f5e95.tar.gz
update 0.8.3, removed unneeded conflicts, changed desc, added install script
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD12
-rw-r--r--notion-enhancer14
4 files changed, 28 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7d6275d180b..ff5bddf27205 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = notion-enhancer
- pkgdesc = An enhancer / customiser for the Notion productivity software
- pkgver = 0.8.0
- pkgrel = 2
+ pkgdesc = An enhancer/customiser for the all-in-one productivity workspace notion.so
+ pkgver = 0.8.3
+ pkgrel = 1
url = https://github.com/dragonwocky/notion-enhancer
+ install = notion-enhancer
arch = any
license = MIT
makedepends = npm
@@ -10,10 +11,9 @@ pkgbase = notion-enhancer
depends = notion-app>=1:2.0.7-3.2
depends = nodejs>=14.8.0-1
depends = asar>=3.0.3-1
- conflicts = notion-enhancer
- noextract = notion-enhancer-0.8.0.tgz
- source = https://registry.npmjs.org/notion-enhancer/-/notion-enhancer-0.8.0.tgz
- md5sums = SKIP
+ noextract = notion-enhancer-0.8.3.tgz
+ source = https://registry.npmjs.org/notion-enhancer/-/notion-enhancer-0.8.3.tgz
+ md5sums = a8b9cb8b7ab7d43bf31d6eedca8f9e9e
pkgname = notion-enhancer
diff --git a/.gitignore b/.gitignore
index ffc816dd1fc0..81991aa354fd 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!notion-enhancer
diff --git a/PKGBUILD b/PKGBUILD
index 727c35f49de0..c7850bc043b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Nek.12 <vaizin.nikita@gmail.com>
pkgname='notion-enhancer'
-pkgver=0.8.0
-pkgrel=3
-pkgdesc="An enhancer / customiser for the Notion productivity software"
+pkgver=0.8.3
+pkgrel=1
+pkgdesc="An enhancer/customiser for the all-in-one productivity workspace notion.so"
arch=('any')
url="https://github.com/dragonwocky/notion-enhancer"
license=(MIT)
@@ -12,14 +12,14 @@ depends=('notion-app>=1:2.0.7-3.2'
'asar>=3.0.3-1')
makedepends=('npm' 'jq')
provides=()
-conflicts=("${pkgname%-git}")
+conflicts=()
replaces=()
backup=()
options=()
-install=
+install=$pkgname
source=("https://registry.npmjs.org/notion-enhancer/-/$pkgname-$pkgver.tgz")
noextract=("${pkgname}-${pkgver}.tgz" )
-md5sums=('303e9c63cbb4981f3d290578afa6f3e7')
+md5sums=('a8b9cb8b7ab7d43bf31d6eedca8f9e9e')
package() {
npm install -g --user root --cache "${srcdir}/npm-cache" --prefix "${pkgdir}/usr" "${srcdir}/${pkgname}-${pkgver}.tgz"
diff --git a/notion-enhancer b/notion-enhancer
new file mode 100644
index 000000000000..7fcd970325ec
--- /dev/null
+++ b/notion-enhancer
@@ -0,0 +1,14 @@
+post_upgrade() {
+ if [[ "$(notion-enhancer check)" == "notion-enhancer has not been applied." ]]; then
+ echo "W: Notion-enhancer is not applied, skipping"
+ else
+ echo "Reapplying notion-enhancer"
+ notion-enhancer apply -y
+ fi
+}
+
+## arg 1: the old package version
+pre_remove() {
+ echo "Disabling notion-enhancer..."
+ notion-enhancer remove -y
+}