summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfivedigits2015-07-30 10:22:16 +0200
committerfivedigits2015-07-30 10:22:16 +0200
commit52c4812e31fac74c9bfe9476b71b8c7da9a3605e (patch)
tree6da0efaab24b3cfe6a615fe41dc326d2aa9e6332
downloadaur-52c4812e31fac74c9bfe9476b71b8c7da9a3605e.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--MIT-LICENSE19
-rw-r--r--PKGBUILD34
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7814dd3d552a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = notmuch-addrlookup-c
+ pkgdesc = A tool to query the notmuch database for addresses.
+ pkgver = v5
+ pkgrel = 1
+ url = https://github.com/aperezdc/notmuch-addrlookup-c
+ arch = any
+ license = MIT
+ depends = notmuch
+ source = https://github.com/aperezdc/notmuch-addrlookup-c/archive/v5.tar.gz
+ source = MIT-LICENSE
+ md5sums = d87ddb9b0f119694bbfe7c086f20907b
+ md5sums = f9be2430c190c736214e76ead254ed07
+
+pkgname = notmuch-addrlookup-c
+
diff --git a/MIT-LICENSE b/MIT-LICENSE
new file mode 100644
index 000000000000..4041a206e0fa
--- /dev/null
+++ b/MIT-LICENSE
@@ -0,0 +1,19 @@
+Copyright (c) 2014 Adrian Perez de Castro <aperez@igalia.com>
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3dd1905eb90f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Moritz Schoenherr <moritz.schoenherr[at]gmail[dot]com>
+pkgname=notmuch-addrlookup-c
+pkgver=v5
+pkgrel=1
+pkgdesc="A tool to query the notmuch database for addresses."
+url="https://github.com/aperezdc/notmuch-addrlookup-c"
+arch=('any')
+license=('MIT')
+depends=('notmuch')
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+source=("https://github.com/aperezdc/notmuch-addrlookup-c/archive/${pkgver}.tar.gz"
+ "MIT-LICENSE")
+
+md5sums=('d87ddb9b0f119694bbfe7c086f20907b'
+ 'f9be2430c190c736214e76ead254ed07')
+
+build() {
+
+ cd "${srcdir}/${pkgname}-${pkgver:1:1}"
+
+ make
+}
+
+package() {
+
+ install -Dm644 "${srcdir}/MIT-LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/MIT-LICENSE"
+
+ cd "${srcdir}/${pkgname}-${pkgver:1:1}"
+
+ install -D notmuch-addrlookup $pkgdir/usr/bin/notmuch-addrlookup
+}