summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReto Brunner2020-04-28 00:05:53 +0200
committerReto Brunner2020-04-28 00:06:07 +0200
commita59072aa41802c4daf9e8ec56c3f315467d61b22 (patch)
tree69be4ad493fe7274efddb0515d550d8d9b954cad
parentd52653ce4dbc4fd13e88a64f19b97d091f3ce981 (diff)
downloadaur-a59072aa41802c4daf9e8ec56c3f315467d61b22.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 20 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2c962cbc5af..d2871649ae80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = notmuch-extract-patch-git
pkgdesc = Extract git patchset from notmuch emails
- pkgver = 1
- pkgrel = 3
+ pkgver = r4.f732a53
+ pkgrel = 2
url = https://github.com/aaptel/notmuch-extract-patch
- arch = i686
- arch = x86_64
+ arch = any
license = GPLv3
makedepends = git
- depends = notmuch
depends = python
- provides = notmuch-extract-patch
- conflicts = notmuch-extract-patch
- source = git+https://github.com/aaptel/notmuch-extract-patch
- md5sums = SKIP
+ depends = notmuch-runtime
+ source = git+https://github.com/aaptel/notmuch-extract-patch.git
+ sha256sums = SKIP
pkgname = notmuch-extract-patch-git
diff --git a/PKGBUILD b/PKGBUILD
index 8e2ff169a157..572cb4cbf108 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
-# Maintainer: Genki Sky <alt+archlinux.org@genki.is>
-
+# Maintainer: Reto <reto@labrat.space>
pkgname=notmuch-extract-patch-git
-pkgver=1
-pkgrel=3
+_realname=${pkgname%-git}
+pkgver=r4.f732a53
+pkgrel=2
pkgdesc='Extract git patchset from notmuch emails'
-arch=('i686' 'x86_64')
url='https://github.com/aaptel/notmuch-extract-patch'
+arch=('any')
license=('GPLv3')
-depends=('notmuch' 'python')
+depends=('python' 'notmuch-runtime')
makedepends=('git')
-provides=('notmuch-extract-patch')
-conflicts=('notmuch-extract-patch')
-source=('git+https://github.com/aaptel/notmuch-extract-patch')
-md5sums=('SKIP')
+source=(
+ 'git+https://github.com/aaptel/notmuch-extract-patch.git'
+)
+sha256sums=('SKIP')
pkgver() {
- cd notmuch-extract-patch
- git log -1 --format='%cd.%h' --date=short | tr -d -
+ cd $_realname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd notmuch-extract-patch
- install -D -m 0755 notmuch-extract-patch "$pkgdir"/usr/bin/notmuch-extract-patch
+ cd $_realname
+ install -Dm755 "${_realname}" "${pkgdir}/usr/bin/${_realname}"
}