summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-09-07 08:34:23 +0200
committerhaawda2018-09-07 08:34:23 +0200
commit62f790612e59b0dee16d9ee86803460557ef3750 (patch)
treeab1be3d90c59423ba9ae0893a0379e3f410909d0
parent65fe38f1e3c4ef383af766964c1fcf11029bb7c4 (diff)
downloadaur-62f790612e59b0dee16d9ee86803460557ef3750.tar.gz
fix git makedependency
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD47
2 files changed, 25 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e4b5c9e3130..bea794673356 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = notmuch-git
- pkgver = 0.26.1.14.g9f1c7c2
+ pkgver = 0.27.1.28.g87934c43
pkgrel = 1
epoch = 3
url = https://notmuchmail.org/
@@ -10,6 +10,7 @@ pkgbase = notmuch-git
makedepends = python
makedepends = python-sphinx
makedepends = emacs
+ makedepends = git
makedepends = gnupg
makedepends = ruby
makedepends = pkgconfig
@@ -30,7 +31,6 @@ pkgname = notmuch-emacs-git
optdepends = gnupg: for email encryption
provides = notmuch
conflicts = notmuch
- replaces = notmuch-git
pkgname = notmuch-runtime-git
pkgdesc = Runtime for notmuch and notmuch-mutt
diff --git a/PKGBUILD b/PKGBUILD
index a0789d9ade32..279acb563d98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,36 +7,36 @@
pkgbase=notmuch-git
arch=('i686' 'x86_64')
-_pkgbase=notmuch
pkgname=('notmuch-emacs-git' 'notmuch-runtime-git' 'notmuch-python-git' 'notmuch-python2-git' 'notmuch-ruby-git' 'notmuch-vim-git' 'notmuch-mutt-git')
epoch=3
-pkgver=0.26.1.14.g9f1c7c2
+pkgver=0.27.1.28.g87934c43
pkgrel=1
url="https://notmuchmail.org/"
license=('GPL3')
-makedepends=('python2' 'python' 'python-sphinx' 'emacs' 'gnupg' 'ruby' 'pkgconfig' 'xapian-core' 'gmime' 'talloc')
+makedepends=('python2' 'python' 'python-sphinx' 'emacs' 'git'
+ 'gnupg' 'ruby' 'pkgconfig' 'xapian-core' 'gmime' 'talloc')
options=(!distcc !makeflags)
source=("git+https://github.com/notmuch/notmuch")
md5sums=('SKIP')
pkgver() {
- cd "$_pkgbase"
+ cd "${pkgbase%-git}"
git describe --long --tags|tr - . |tr -d "debian/"
}
prepare(){
- cd "$_pkgbase"
- cp -dpr --no-preserve=ownership "$srcdir"/$_pkgbase/bindings/python{,2}
- find "$srcdir/${_pkgbase}/bindings/python" -name '*.py' -exec sed -i -e '1s,python$,python3,' {} +
- find "$srcdir/${_pkgbase}/bindings/python2" -name '*.py' -exec sed -i -e '1s,python$,python2,' {} +
+ cd "${pkgbase%-git}"
+ cp -dpr --no-preserve=ownership "$srcdir"/${pkgbase%-git}/bindings/python{,2}
+ find "$srcdir/${pkgbase%-git}/bindings/python" -name '*.py' -exec sed -i -e '1s,python$,python3,' {} +
+ find "$srcdir/${pkgbase%-git}/bindings/python2" -name '*.py' -exec sed -i -e '1s,python$,python2,' {} +
}
build() {
- cd "$_pkgbase"
+ cd "${pkgbase%-git}"
./configure --prefix=/usr --sysconfdir=/etc --includedir=/usr/include --without-zsh-completion
make
- make -C "contrib/${_pkgbase}-mutt" "${_pkgbase}-mutt.1"
+ make -C "contrib/${pkgbase%-git}-mutt" "${pkgbase%-git}-mutt.1"
make ruby-bindings
@@ -54,10 +54,9 @@ package_notmuch-emacs-git(){
optdepends=('emacs: for using the emacs interface' 'gnupg: for email encryption')
conflicts=('notmuch')
provides=('notmuch')
- replaces=('notmuch-git')
install=notmuch.install
-
- cd "$_pkgbase"
+
+ cd "${pkgbase%-git}"
make DESTDIR="$pkgdir/" install-emacs
rm "$pkgdir/usr/share/applications/mimeinfo.cache"
}
@@ -68,12 +67,12 @@ package_notmuch-runtime-git(){
depends=('xapian-core' 'gmime' 'talloc')
conflicts=('notmuch-runtime')
provides=('notmuch-runtime')
- cd "$_pkgbase"
+ cd "${pkgbase%-git}"
make DESTDIR="$pkgdir/" LIBDIR_IN_LDCONFIG=0 WITH_EMACS=0 install
# install manpages
- make DESTDIR="$pkgdir" prefix="/usr" install-man
+ make DESTDIR="$pkgdir" prefix=/usr install-man
# install binary
install -Dm755 notmuch "$pkgdir/usr/bin/notmuch"
@@ -90,7 +89,7 @@ package_notmuch-vim-git(){
conflicts=('notmuch-vim')
provides=('notmuch-vim')
- make -C "$_pkgbase"/vim DESTDIR="$pkgdir" prefix="/usr/share/vim/vimfiles" install
+ make -C "${pkgbase%-git}"/vim DESTDIR="$pkgdir" prefix="/usr/share/vim/vimfiles" install
}
package_notmuch-python-git(){
@@ -101,7 +100,7 @@ package_notmuch-python-git(){
conflicts=('notmuch-python')
provides=('notmuch-python')
- cd "$_pkgbase"/bindings/python
+ cd "${pkgbase%-git}"/bindings/python
python setup.py install --prefix=/usr --root="$pkgdir"
}
@@ -112,7 +111,7 @@ package_notmuch-python2-git(){
optdepends=('python2: for using the python2 bindings')
conflicts=('notmuch-python2')
provides=('notmuch-python2')
- cd "$_pkgbase"/bindings/python2
+ cd "${pkgbase%-git}"/bindings/python2
python2 setup.py install --prefix=/usr --root="$pkgdir"
}
@@ -124,10 +123,10 @@ package_notmuch-ruby-git(){
conflicts=('notmuch-ruby')
provides=('notmuch-ruby')
- cd $_pkgbase
+ cd ${pkgbase%-git}
sed -i 's:INSTALL = .*[^D]$:& -D:' bindings/ruby/Makefile
- install -d $pkgdir/usr/lib/ruby/vendor_ruby/2.4.0/x86_64-linux
- make -C bindings/ruby exec_prefix=$pkgdir/usr prefix=/usr install
+ install -d "$pkgdir"/usr/lib/ruby/vendor_ruby/2.4.0/x86_64-linux
+ make -C bindings/ruby exec_prefix="$pkgdir"/usr prefix=/usr install
}
package_notmuch-mutt-git(){
@@ -137,8 +136,8 @@ package_notmuch-mutt-git(){
conflicts=('notmuch-mutt')
provides=('notmuch-mutt')
- cd "$_pkgbase"
+ cd ${pkgbase%-git}
- install -Dm755 "contrib/${_pkgbase}-mutt/${_pkgbase}-mutt" "$pkgdir/usr/bin/${_pkgbase}-mutt"
- install -Dm644 "contrib/${_pkgbase}-mutt/${_pkgbase}-mutt.1" "${pkgdir}/usr/share/man/man1/${_pkgbase}-mutt.1"
+ install -Dm755 "contrib/${pkgbase%-git}-mutt/${pkgbase%-git}-mutt" "$pkgdir"/usr/bin/${pkgbase%-git}-mutt
+ install -Dm644 "contrib/${pkgbase%-git}-mutt/${pkgbase%-git}-mutt.1" "${pkgdir}"/usr/share/man/man1/${pkgbase%-git}-mutt.1
}