summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-04-11 07:02:47 +0200
committerhaawda2017-04-11 07:02:47 +0200
commitef215326571398ceb57fa9e660ce4b3fee6e5fd9 (patch)
treef2b8c27b107593d54cc0419a9168448bb9acf52a
downloadaur-ef215326571398ceb57fa9e660ce4b3fee6e5fd9.tar.gz
initial upload
-rw-r--r--.SRCINFO65
-rw-r--r--PKGBUILD121
-rw-r--r--not_byte_compile_notmuch_el.patch12
-rw-r--r--notmuch.install8
4 files changed, 206 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c61cc85db1f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,65 @@
+# Generated by mksrcinfo v8
+# Tue Apr 11 05:01:28 UTC 2017
+pkgbase = notmuch-git
+ pkgver = 0.24.1.59.gce8c8882
+ pkgrel = 1
+ url = https://notmuchmail.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = python2
+ makedepends = python
+ makedepends = python-sphinx
+ makedepends = emacs
+ makedepends = gnupg
+ makedepends = ruby
+ makedepends = pkgconfig
+ makedepends = xapian-core
+ makedepends = gmime
+ makedepends = talloc
+ options = !distcc
+ options = !makeflags
+ source = git://notmuchmail.org/git/notmuch
+ source = not_byte_compile_notmuch_el.patch
+ md5sums = SKIP
+ md5sums = 07fa5cbbf2c7e0d5a19352c652e9c9cf
+
+pkgname = notmuch-git
+ pkgdesc = Not much of an email program
+ install = notmuch.install
+ depends = notmuch-runtime
+ optdepends = emacs: for using the emacs interface
+ optdepends = vim: for using the vim interface
+ optdepends = python2: for using the python2 bindings
+ optdepends = ruby: for using the ruby bindings
+ optdepends = gnupg: for email encryption
+ provides = ${pkgname//-git}
+ conflicts = ${pkgname//-git}
+
+pkgname = notmuch-vim-git
+ pkgdesc = Vim plugins for notmuch
+ arch = any
+ depends = notmuch-runtime-git
+ provides = ${pkgname//-git}
+ conflicts = ${pkgname//-git}
+
+pkgname = notmuch-mutt-git
+ pkgdesc = The mail indexer
+ arch = any
+ depends = notmuch-runtime
+ depends = perl-mailtools
+ depends = perl-mail-box
+ depends = perl-term-readline-gnu
+ depends = perl-string-shellquote
+ depends = perl-file-which
+ provides = ${pkgname//-git}
+ conflicts = ${pkgname//-git}
+
+pkgname = notmuch-runtime-git
+ pkgdesc = Runtime for notmuch and notmuch-mutt
+ depends = xapian-core
+ depends = gmime
+ depends = talloc
+ provides = ${pkgname//-git}
+ conflicts = ${pkgname//-git}
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..79bde530cc4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,121 @@
+# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
+# Contributor: fauno <fauno at kiwwwi.com.ar>
+# Contributor: Olivier Ramonat <olivier at ramonat dot fr>
+# Contributor: Richard Murri <admin@richardmurri.com>
+
+pkgbase=notmuch-git
+_pkgname=notmuch
+pkgname=('notmuch-git' 'notmuch-vim-git' 'notmuch-mutt-git' 'notmuch-runtime-git')
+pkgver=0.24.1.59.gce8c8882
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://notmuchmail.org/"
+license=('GPL3')
+makedepends=('python2' 'python' 'python-sphinx' 'emacs' 'gnupg' 'ruby' 'pkgconfig' 'xapian-core' 'gmime' 'talloc')
+options=(!distcc !makeflags)
+source=("git://notmuchmail.org/git/notmuch" not_byte_compile_notmuch_el.patch)
+md5sums=('SKIP'
+ '07fa5cbbf2c7e0d5a19352c652e9c9cf')
+
+pkgver() {
+ cd ${_pkgname}
+ git describe --long --tags|tr - .
+}
+
+prepare(){
+ cp -dpr --no-preserve=ownership "$srcdir/${_pkgname}"/bindings/python{,2}
+ find "$srcdir/${_pkgname}/bindings/python" -name '*.py' -exec sed -i -e '1s,python$,python3,' {} +
+ find "$srcdir/${_pkgname}/bindings/python2" -name '*.py' -exec sed -i -e '1s,python$,python2,' {} +
+ cd $_pkgname
+ patch -Np1 < $srcdir/not_byte_compile_notmuch_el.patch||true
+}
+
+build() {
+ cd $_pkgname
+
+ ./configure --prefix=/usr --sysconfdir=/etc --includedir=/usr/include --without-zsh-completion
+ make
+
+ make -C "contrib/${_pkgname}-mutt" "${_pkgname}-mutt.1"
+
+ make ruby-bindings
+
+ cd bindings/python
+ python setup.py build
+ cd -
+ cd bindings/python2
+ python2 setup.py build
+}
+
+package_notmuch-runtime-git(){
+ pkgdesc="Runtime for notmuch and notmuch-mutt"
+ depends=('xapian-core' 'gmime' 'talloc')
+ conflicts=('${pkgname//-git}')
+ provides=('${pkgname//-git}')
+ cd $_pkgname
+
+ make DESTDIR="$pkgdir/" LIBDIR_IN_LDCONFIG=0 WITH_EMACS=0 install
+
+ install -Dm755 notmuch "$pkgdir/usr/bin/notmuch"
+ rm -rf "$pkgdir/usr/share"
+}
+
+
+package_notmuch-vim-git(){
+ arch=('any')
+ pkgdesc="Vim plugins for notmuch"
+ depends=('notmuch-runtime-git')
+ conflicts=('${pkgname//-git}')
+ provides=('${pkgname//-git}')
+
+ make -C ${_pkgname}/vim DESTDIR="$pkgdir" prefix="/usr/share/vim/vimfiles" install
+}
+
+
+package_notmuch-git(){
+ pkgdesc="Not much of an email program"
+ depends=('notmuch-runtime')
+ optdepends=('emacs: for using the emacs interface'
+ 'vim: for using the vim interface'
+ 'python2: for using the python2 bindings'
+ 'ruby: for using the ruby bindings'
+ 'gnupg: for email encryption')
+ conflicts=('${pkgname//-git}')
+ provides=('${pkgname//-git}')
+
+ install=notmuch.install
+
+ cd $_pkgname
+
+ # Install emacs parts
+ make DESTDIR="$pkgdir/" install-emacs
+
+ # Install manpages
+ make DESTDIR="$pkgdir" prefix="/usr" install-man
+
+ # Install ruby bindings
+ sed -i 's:INSTALL = .*[^D]$:& -D:' bindings/ruby/Makefile
+ make -C bindings/ruby exec_prefix=$pkgdir/usr prefix=/usr install
+
+ # Install python bindings
+ cd bindings/python
+ python setup.py install --prefix=/usr --root="$pkgdir"
+ cd -
+ cd bindings/python2
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+ rm "$pkgdir"/usr/share/applications/mimeinfo.cache
+}
+
+package_notmuch-mutt-git(){
+ arch=('any')
+ pkgdesc="The mail indexer"
+ depends=('notmuch-runtime' 'perl-mailtools' 'perl-mail-box' 'perl-term-readline-gnu' 'perl-string-shellquote' 'perl-file-which')
+ conflicts=('${pkgname//-git}')
+ provides=('${pkgname//-git}')
+
+ cd ${_pkgname}
+
+ install -Dm755 "contrib/${_pkgname}-mutt/${_pkgname}-mutt" "$pkgdir/usr/bin/${_pkgname}-mutt"
+ install -Dm644 "contrib/${_pkgname}-mutt/${_pkgname}-mutt.1" "${pkgdir}/usr/share/man/man1/${_pkgname}-mutt.1"
+}
diff --git a/not_byte_compile_notmuch_el.patch b/not_byte_compile_notmuch_el.patch
new file mode 100644
index 000000000000..e2a4f8435cf4
--- /dev/null
+++ b/not_byte_compile_notmuch_el.patch
@@ -0,0 +1,12 @@
+diff --git a/emacs/Makefile.local b/emacs/Makefile.local
+index 040e64d4..acd5b078 100644
+--- a/emacs/Makefile.local
++++ b/emacs/Makefile.local
+@@ -5,7 +5,6 @@ emacs_sources := \
+ $(dir)/notmuch-lib.el \
+ $(dir)/notmuch-compat.el \
+ $(dir)/notmuch-parser.el \
+- $(dir)/notmuch.el \
+ $(dir)/notmuch-query.el \
+ $(dir)/notmuch-show.el \
+ $(dir)/notmuch-tree.el \
diff --git a/notmuch.install b/notmuch.install
new file mode 100644
index 000000000000..a683eedb4ea6
--- /dev/null
+++ b/notmuch.install
@@ -0,0 +1,8 @@
+post_upgrade() {
+ if (( $(vercmp $2 0.20) < 0 )); then
+ cat <<"EOF"
+==> notmuch-deliver was removed in notmuch 0.20.
+==> Please use `notmuch insert` instead.
+EOF
+ fi
+}