summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLen Zhang2016-07-10 13:47:28 -0400
committerLen Zhang2016-07-10 13:47:28 -0400
commita953c931bd8502cf946e50d7512b34475b342ef1 (patch)
tree1ff7a70dd926244a36c37eeee14c5af82a49c664
downloadaur-a953c931bd8502cf946e50d7512b34475b342ef1.tar.gz
init commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
-rw-r--r--noto-fonts-cjk-otf.install11
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f9cd5075116
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = noto-fonts-cjk-otf
+ pkgdesc = Google Noto CJK fonts, use OTF type to solve some font fallback problems
+ pkgver = 1.004
+ pkgrel = 1
+ url = https://www.google.com/get/noto/
+ install = noto-fonts-cjk-otf.install
+ arch = any
+ license = custom:SIL
+ depends = fontconfig
+ provides = noto-fonts-cjk=1.004
+ conflicts = noto-fonts-cjk
+ source = https://github.com/googlei18n/noto-cjk/archive/v1.004.tar.gz
+ sha256sums = 835a42755c1e8d6a4a406f32609da1f0fa7f9674d05760f0be658d9d6f4ab71c
+
+pkgname = noto-fonts-cjk-otf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a789ad5e5b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Len Zhang <zyldragoon@gmail.com>
+
+pkgname=noto-fonts-cjk-otf
+pkgver=1.004
+pkgrel=1
+pkgdesc="Google Noto CJK fonts, use OTF type to solve some font fallback problems"
+arch=(any)
+url="https://www.google.com/get/noto/"
+license=(custom:SIL)
+depends=(fontconfig)
+conflicts=('noto-fonts-cjk')
+provides=("noto-fonts-cjk=$pkgver")
+install=$pkgname.install
+source=("https://github.com/googlei18n/noto-cjk/archive/v$pkgver.tar.gz")
+sha256sums=('835a42755c1e8d6a4a406f32609da1f0fa7f9674d05760f0be658d9d6f4ab71c')
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/fonts/OTF/noto-cjk
+ install -m644 noto-cjk-$pkgver/*.otf "$pkgdir"/usr/share/fonts/OTF/noto-cjk
+ install -Dm644 noto-cjk-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/noto-fonts-cjk-otf.install b/noto-fonts-cjk-otf.install
new file mode 100644
index 000000000000..ac6cb5b6f4ac
--- /dev/null
+++ b/noto-fonts-cjk-otf.install
@@ -0,0 +1,11 @@
+post_install() {
+ fc-cache -s
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}