summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaire Charron2015-12-27 14:12:28 -0500
committerClaire Charron2015-12-27 14:12:28 -0500
commit21a7936d2185c0bc7952e89a5076f652d43e2428 (patch)
treeb2591d33d73dc7a9e4f406834d53c2e8fde36acc
downloadaur-21a7936d2185c0bc7952e89a5076f652d43e2428.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD44
-rw-r--r--noto-fonts-emoji.install11
-rw-r--r--noto-fonts-emoji.patch13
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ac720c32e23
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Sun Dec 27 19:11:01 UTC 2015
+pkgbase = noto-fonts-emoji-git
+ pkgdesc = Google Noto emoji fonts
+ pkgver = r81.9417128
+ pkgrel = 1
+ url = https://www.google.com/get/noto/
+ install = noto-fonts-emoji.install
+ arch = any
+ license = Apache
+ makedepends = cairo
+ makedepends = git
+ makedepends = optipng
+ makedepends = python2-fonttools
+ makedepends = nototools
+ makedepends = zopflipng-git
+ depends = fontconfig
+ provides = noto-fonts-emoji
+ conflicts = noto-fonts-emoji
+ source = noto-fonts-emoji::git+https://github.com/googlei18n/noto-emoji.git
+ source = noto-fonts-emoji.patch
+ sha512sums = SKIP
+ sha512sums = 72f3c82ba3a1e69c158c3238c4c817df3e77302071ec1094fb284863ee72fb00117d89531ba75412501507984df4561ad013a09ac5742728c240bf073d80f4d0
+
+pkgname = noto-fonts-emoji-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..387823ad3381
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id: PKGBUILD 249884 2015-10-30 21:49:02Z arojas $
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Claire Charron <claire@undeterminant.net>
+
+_pkgname=noto-fonts-emoji
+pkgname=$_pkgname-git
+pkgver=r81.9417128
+pkgrel=1
+pkgdesc="Google Noto emoji fonts"
+arch=(any)
+url="https://www.google.com/get/noto/"
+license=(Apache)
+provides=($_pkgname)
+conflicts=($_pkgname)
+depends=(fontconfig)
+makedepends=(cairo git optipng python2-fonttools nototools zopflipng-git)
+install=$_pkgname.install
+source=("$_pkgname::git+https://github.com/googlei18n/noto-emoji.git"
+ "$_pkgname.patch")
+sha512sums=('SKIP'
+ '72f3c82ba3a1e69c158c3238c4c817df3e77302071ec1094fb284863ee72fb00117d89531ba75412501507984df4561ad013a09ac5742728c240bf073d80f4d0')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_pkgname"
+ patch -i ../$_pkgname.patch
+ find -name '*.py' | xargs sed -e 's|/usr/bin/env python|/usr/bin/env python2|' -i
+ sed -e 's|python|python2|g' -e 's|ttx "$<"|ttx2 "$<"|g' -i Makefile
+}
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ mkdir -p "$pkgdir"/usr/share/fonts/noto
+ install -m644 NotoColorEmoji.ttf fonts/NotoEmoji-Regular.ttf "$pkgdir"/usr/share/fonts/noto
+}
diff --git a/noto-fonts-emoji.install b/noto-fonts-emoji.install
new file mode 100644
index 000000000000..ac6cb5b6f4ac
--- /dev/null
+++ b/noto-fonts-emoji.install
@@ -0,0 +1,11 @@
+post_install() {
+ fc-cache -s
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
diff --git a/noto-fonts-emoji.patch b/noto-fonts-emoji.patch
new file mode 100644
index 000000000000..30dbe0ff9b16
--- /dev/null
+++ b/noto-fonts-emoji.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 324165e..812979f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -71,7 +71,7 @@ SELECTED_FLAGS = AD AE AF AG AI AL AM AO AR AS AT AU AW AX AZ \
+ ZA ZM ZW
+ ALL_FLAGS = $(basename $(notdir $(wildcard $(FLAGS_SRC_DIR)/*.png)))
+
+-FLAGS = $(SELECTED_FLAGS)
++FLAGS = $(ALL_FLAGS)
+
+ FLAG_NAMES = $(FLAGS:%=%.png)
+ FLAG_FILES = $(addprefix $(FLAGS_DIR)/, $(FLAG_NAMES))