summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAriel Dabalsa2016-12-28 14:06:16 -0500
committerAriel Dabalsa2016-12-28 14:06:16 -0500
commit42a7d2cd3ea0387d2f9bbe19a2bd8473e2bcf5a5 (patch)
tree6a8a20ee4a5b26e691aa29c7729978c14dd97adb
downloadaur-42a7d2cd3ea0387d2f9bbe19a2bd8473e2bcf5a5.tar.gz
Init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD19
-rw-r--r--noto-fonts-tc.install15
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e58584be2a9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Dec 28 19:04:43 UTC 2016
+pkgbase = noto-fonts-tc
+ pkgdesc = Noto CJK-TC fonts for Traditional Chinese
+ pkgver = 20150617
+ pkgrel = 1
+ url = https://github.com/googlei18n/noto-cjk/archive/v1.004.zip
+ install = noto-fonts-tc.install
+ arch = any
+ license = custom: SIL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://github.com/googlei18n/noto-cjk/raw/master/NotoSansCJKtc-Regular.otf
+ source = https://github.com/googlei18n/noto-cjk/raw/master/NotoSansMonoCJKtc-Regular.otf
+ sha1sums = SKIP
+ sha1sums = SKIP
+
+pkgname = noto-fonts-tc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1d7bbc2fb61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: <ariel.dabalsa@gmail.com>
+
+pkgname=noto-fonts-tc
+pkgver=20150617
+pkgrel=1
+pkgdesc="Noto CJK-TC fonts for Traditional Chinese"
+arch=(any)
+depends=(fontconfig xorg-font-utils)
+source=("https://github.com/googlei18n/noto-cjk/raw/master/NotoSansCJKtc-Regular.otf"
+ "https://github.com/googlei18n/noto-cjk/raw/master/NotoSansMonoCJKtc-Regular.otf")
+url="https://github.com/googlei18n/noto-cjk/archive/v1.004.zip"
+install=${pkgname}.install
+license=("custom: SIL")
+sha1sums=('SKIP' 'SKIP')
+
+package() {
+ install -d "${pkgdir}/usr/share/fonts/OTF"
+ install -m644 "${srcdir}/"*.otf "${pkgdir}/usr/share/fonts/OTF/"
+}
diff --git a/noto-fonts-tc.install b/noto-fonts-tc.install
new file mode 100644
index 000000000000..477228553e82
--- /dev/null
+++ b/noto-fonts-tc.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}