summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriele Musco2020-05-19 11:40:14 +0200
committerGabriele Musco2020-05-19 11:40:14 +0200
commitcee7c60b2767718d38c9353e2a531bd16073eb04 (patch)
treee224242a213b191d086d0cbfb93db89fe722a1d5
downloadaur-cee7c60b2767718d38c9353e2a531bd16073eb04.tar.gz
first release
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47305d726369
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = notorious-git
+ pkgdesc = Keyboard centric notes
+ pkgver = 0.1.r0.g2f22906
+ pkgrel = 1
+ url = https://gitlab.gnome.org/gabmus/notorious
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ depends = gtk3
+ depends = python
+ depends = libhandy
+ depends = python-gobject
+ depends = gobject-introspection
+ provides = notorious
+ conflicts = notorious
+ source = notorious::git+https://gitlab.gnome.org/gabmus/notorious
+ sha256sums = SKIP
+
+pkgname = notorious-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fddee0028d82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Gabriele Musco <gabmus@disroot.org>
+# Upstream URL: https://gitlab.gnome.org/gabmus/notorious
+
+pkgname=notorious-git
+pkgver=0.1.r0.g2f22906
+pkgrel=1
+pkgdesc='Keyboard centric notes'
+arch=('any')
+url='https://gitlab.gnome.org/gabmus/notorious'
+license=('GPL3')
+depends=(
+ 'gtk3'
+ 'python'
+ 'libhandy'
+ 'python-gobject'
+ 'gobject-introspection'
+)
+makedepends=('git' 'meson')
+provides=('notorious')
+conflicts=('notorious')
+source=("notorious::git+https://gitlab.gnome.org/gabmus/notorious")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/notorious"
+ git describe --long --tags --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/notorious"
+ rm -rf build
+ mkdir build
+ cd build
+ meson --prefix /usr --buildtype release ..
+ ninja
+}
+
+package() {
+ cd "$srcdir/notorious"
+ cd build
+ DESTDIR="$pkgdir" ninja install
+}