summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-10-07 23:30:18 +0300
committerorhun2020-10-07 23:30:18 +0300
commitbf738123a1b6dd81063a1bc08e12ed3f2768e30f (patch)
treef3b263b527207d5d51bf9f3fc68bd4d39b536f17
parent86ae830df75e3cfe3b72a6b5f3ff125f996a4331 (diff)
downloadaur-bf738123a1b6dd81063a1bc08e12ed3f2768e30f.tar.gz
upgpkg: notp-bin 2.1.0-1
upstream release Update sources
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4ee809ca793..f8b6419ec6b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,12 +5,15 @@ pkgbase = notp-bin
url = https://github.com/kondanta/notp
arch = x86_64
license = MIT
+ provides = notp
conflicts = notp
conflicts = notp-git
- source = notp::https://github.com/kondanta/notp/releases/download/v2.1.0/notp_linux
- source = notp-2.1.0-LICENSE::https://github.com/kondanta/notp/raw/v2.1.0/LICENSE
- sha512sums = 89d717d71233dcc418e36af66929a3c38ae78195d2656d8f77732fd7bf3062fff1f0592868a1473fde2168f181e896e98f2afc8c277bcfeeeb01b923e3c73b7d
- sha512sums = 57f4d16bb970bbff5d94b0cc62729948ce2fdb929df6023ed1e9192209da36b0f4c309b5d42cf93edbbe18c49fe35ab91ea6d59e47f3813cfa59009e61539861
+ source_x86_64 = notp::https://github.com/kondanta/notp/releases/download/v2.1.0/notp_linux
+ source_x86_64 = notp-2.1.0-LICENSE::https://github.com/kondanta/notp/raw/v2.1.0/LICENSE
+ source_x86_64 = notp-2.1.0-README.md::https://github.com/kondanta/notp/raw/v2.1.0/README.md
+ sha512sums_x86_64 = 89d717d71233dcc418e36af66929a3c38ae78195d2656d8f77732fd7bf3062fff1f0592868a1473fde2168f181e896e98f2afc8c277bcfeeeb01b923e3c73b7d
+ sha512sums_x86_64 = 57f4d16bb970bbff5d94b0cc62729948ce2fdb929df6023ed1e9192209da36b0f4c309b5d42cf93edbbe18c49fe35ab91ea6d59e47f3813cfa59009e61539861
+ sha512sums_x86_64 = cdfc2ce8854aa7300c19976ed81f1894ddacd42a48dfbe0ee6cfb94bae8e63e27676c3de691f4105fd76d47acf68310956a00931653c45d6df35a540db6ad9d3
pkgname = notp-bin
diff --git a/PKGBUILD b/PKGBUILD
index ceff6c5a2013..cab289e4ea17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,12 +9,16 @@ arch=('x86_64')
url="https://github.com/kondanta/notp"
license=('MIT')
conflicts=("${pkgname%-bin}" "${pkgname%-bin}-git")
-source=("${pkgname%-bin}::$url/releases/download/v$pkgver/${pkgname%-bin}_linux"
- "${pkgname%-bin}-$pkgver-LICENSE::$url/raw/v$pkgver/LICENSE")
-sha512sums=('89d717d71233dcc418e36af66929a3c38ae78195d2656d8f77732fd7bf3062fff1f0592868a1473fde2168f181e896e98f2afc8c277bcfeeeb01b923e3c73b7d'
- '57f4d16bb970bbff5d94b0cc62729948ce2fdb929df6023ed1e9192209da36b0f4c309b5d42cf93edbbe18c49fe35ab91ea6d59e47f3813cfa59009e61539861')
+provides=("${pkgname%-bin}")
+source_x86_64=("${pkgname%-bin}::$url/releases/download/v$pkgver/${pkgname%-bin}_linux"
+ "${pkgname%-bin}-$pkgver-LICENSE::$url/raw/v$pkgver/LICENSE"
+ "${pkgname%-bin}-$pkgver-README.md::$url/raw/v$pkgver/README.md")
+sha512sums_x86_64=('89d717d71233dcc418e36af66929a3c38ae78195d2656d8f77732fd7bf3062fff1f0592868a1473fde2168f181e896e98f2afc8c277bcfeeeb01b923e3c73b7d'
+ '57f4d16bb970bbff5d94b0cc62729948ce2fdb929df6023ed1e9192209da36b0f4c309b5d42cf93edbbe18c49fe35ab91ea6d59e47f3813cfa59009e61539861'
+ 'cdfc2ce8854aa7300c19976ed81f1894ddacd42a48dfbe0ee6cfb94bae8e63e27676c3de691f4105fd76d47acf68310956a00931653c45d6df35a540db6ad9d3')
package() {
- install -Dt "$pkgdir/usr/bin/" "$srcdir/${pkgname%-bin}"
- install -Dm 644 ${pkgname%-bin}-$pkgver-LICENSE "$pkgdir/usr/share/licenses/${pkgname%-bin}/LICENSE"
-} \ No newline at end of file
+ install -Dm 755 "${pkgname%-bin}" -t "${pkgdir}/usr/bin"
+ install -Dm 644 "${pkgname%-bin}-$pkgver-README.md" "$pkgdir/usr/share/doc/${pkgname%-bin}/README.md"
+ install -Dm 644 "${pkgname%-bin}-$pkgver-LICENSE" "$pkgdir/usr/share/licenses/${pkgname%-bin}/LICENSE"
+}