summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-10-07 23:32:04 +0300
committerorhun2020-10-07 23:32:04 +0300
commitea24fac68a06e4d5dfb3b40435209eeb5f7fc917 (patch)
tree831b9706841e7291d71ee052c382910e52a7ab3b
parentebfd380a87350b7763e7d1107a46dca071ae7de2 (diff)
downloadaur-ea24fac68a06e4d5dfb3b40435209eeb5f7fc917.tar.gz
upgpkg: notp-git 2.1.0.r57.g0aa13af-1
Add provides section
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33008f084dc1..24da6e91499a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = notp-git
license = MIT
makedepends = cargo
makedepends = git
+ provides = notp
conflicts = notp
conflicts = notp-bin
source = git+https://github.com/kondanta/notp
diff --git a/PKGBUILD b/PKGBUILD
index 6da1b72b7fac..d8649cc1651c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,6 +10,7 @@ url="https://github.com/kondanta/notp"
license=('MIT')
makedepends=('cargo' 'git')
conflicts=("${pkgname%-git}" "${pkgname%-git}-bin")
+provides=("${pkgname%-git}")
source=("git+${url}")
sha256sums=('SKIP')
@@ -32,5 +33,5 @@ package() {
cd "${pkgname%-git}"
install -Dm 755 "target/release/${pkgname%-git}" -t "${pkgdir}/usr/bin"
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-git}"
- install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
-} \ No newline at end of file
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
+}