summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKiet "Shihotori" Huynh2025-02-03 19:08:38 +0700
committerKiet "Shihotori" Huynh2025-02-03 19:08:38 +0700
commit46cd57182143d5fee28134599e450d09fc3909c5 (patch)
tree37db8b1ca9dcabff11cf6af13cd1c0ff4474d530
downloadaur-46cd57182143d5fee28134599e450d09fc3909c5.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..35eb498fc05e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = notwaita-cursor-theme-bin
+ pkgdesc = A cursor theme inspired by the Adwaita icons from the GNOME Project for Windows and Linux with HiDPI support.
+ pkgver = 1.0.0_alpha1
+ pkgrel = 1
+ url = https://github.com/ful1e5/notwaita-cursor
+ arch = x86_64
+ license = LGPL-3.0-only
+ provides = notwaita-cursor-theme
+ conflicts = notwaita-cursor-theme
+ source = notwaita-cursor-theme-1.0.0-alpha1.tar.xz::https://github.com/ful1e5/notwaita-cursor/releases/download/v1.0.0-alpha1/Notwaita.tar.xz
+ source = LICENSE::https://raw.githubusercontent.com/ful1e5/notwaita-cursor/refs/heads/main/COPYING_LGPL
+ sha256sums = 93928d9c64e2aa61e061efcfbdbf67ae15c458095c6d82f5ad790a1402d46cf2
+ sha256sums = da7eabb7bafdf7d3ae5e9f223aa5bdc1eece45ac569dc21b3b037520b4464768
+
+pkgname = notwaita-cursor-theme-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7846fd9f9564
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Kiet Huynh <11086238+superkidvn@users.noreply.github.com>
+
+pkgname=notwaita-cursor-theme-bin
+pkgver=1.0.0_alpha1
+pkgrel=1
+pkgdesc="A cursor theme inspired by the Adwaita icons from the GNOME Project for Windows and Linux with HiDPI support."
+arch=('x86_64')
+url="https://github.com/ful1e5/notwaita-cursor"
+license=('LGPL-3.0-only')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=(${pkgname%-bin}-${pkgver//_/-}.tar.xz::"${url}/releases/download/v${pkgver//_/-}/Notwaita.tar.xz"
+ LICENSE::"${url//github.com/raw.githubusercontent.com}/refs/heads/main/COPYING_LGPL")
+sha256sums=('93928d9c64e2aa61e061efcfbdbf67ae15c458095c6d82f5ad790a1402d46cf2'
+ 'da7eabb7bafdf7d3ae5e9f223aa5bdc1eece45ac569dc21b3b037520b4464768')
+prepare(){
+ tar -xf "${pkgname%-bin}-${pkgver//_/-}.tar.xz"
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/icons"
+ cp -r Notwaita-* "${pkgdir}/usr/share/icons"
+}